[R] Issues with TMPDIR/TEMP/TMP? Failure of R CMD check under Windows 7

Ulrike Grömping groemping at bht-berlin.de
Sun Feb 24 22:00:47 CET 2013

Dear helpeRs,

on my Windows 7 laptop, I have problems getting R CMD check to work. I 
believe it did work completely before, but I am not sure.

Yesterday it almost worked, except for the tests: These were aborted 
because of a complaint that the temporary directory wasn't available. I 
played with windows environment variables for the temporary directory, 
but that didn't solve it. Apparently I did something that made things worse:

Today, R CMD check completely refuses to work, with the error message 
"Fatal error: creation of tmpfile failed -- set TMPDIR suitably?" This 
is the same for current R and R-devel. Changes to the TEMP or TMP 
environment variable don't influence this behavior.

The path:
C:\Rtools;C:\Program Files\Dell\DW WLAN Card;C:\Program 
Files\Intel\OpenCL SDK\2.0\bin\x86;C:\Program Files\WIDCOMM\Bluetooth 
Software\;C:\Program Files\Calibre2\;C:\Program Files\MiKTeX 
2.9\miktex\bin\;C:\Program Files\TortoiseSVN\bin

Any ideas what I can do to fix this?
Perhaps also relevant: I run R CMD check from a DOS window that is 
opened with administrator rights.

Best, Ulrike

More information about the R-help mailing list