[R] Another X11 problem. (Psigh!)

Marc Schwartz marc_schwartz at me.com
Sat Jan 12 16:36:10 CET 2013

On Jan 11, 2013, at 10:35 PM, Rolf Turner <rolf.turner at xtra.co.nz> wrote:

> Tried to do a plot just now and got an error:
> Error in text.default(2, 6, main, cex = cex) :
>  X11 font -adobe-helvetica-%s-%s-*-*-%d-*-*-*-*-*-*-*, face 1 at size 16 could not be loaded
> This is reproducible (in my current environment) via:
> par(mfrow=c(2,2))
> plot(1:10)
> text(2,6,"Oh, hell!",cex=2)
> This is of course not the real context in which the error originally
> manifested itself.  The "real context" triggered no such problems
> until I started messing about trying to solve the "inconsolata" font
> problem that I posted about recently.
> Can anyone tell me (in simple comprehensible terms, please) how I might
> make the required font available so that it can be loaded?  I reiterate,
> please keep it simple.  I find fonts toadally incomprehensible!
> Note that I did  as I was advised and installed texlive-2012 for Fedora 17
> following the instructions detailed in the website that was given (and which
> I cited in my previous email).  Didn't help a bit.
> For what it's worth, here is my session info:
>> sessionInfo()
>> R version 2.15.2 Patched (2012-11-15 r61122)
>> Platform: x86_64-unknown-linux-gnu (64-bit)
>> locale:
>> [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C
>> [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8
>> [7] LC_PAPER=C                 LC_NAME=C
>> [9] LC_ADDRESS=C               LC_TELEPHONE=C
>> attached base packages:
>> [1] stats     graphics  grDevices utils     datasets  methods base
>> other attached packages:
>> [1] spatstat_1.30-0 deldir_0.0-21   mgcv_1.7-22     misc_0.0-15
>> loaded via a namespace (and not attached):
>> [1] grid_2.15.2     lattice_0.20-10 Matrix_1.0-10   nlme_3.1-105
>> [5] tools_2.15.2
>    cheers,
>        Rolf Turner

Been a while (years) since I have seen that error message on the lists, but if memory serves, it was typically because you are missing certain X11 fonts. More info in the relevant manual:


>From a quick review you probably need to install:

  xorg-x11-font-utils (you may already have this)


Since I have not used Fedora in several years now, my knowledge base may be a bit dated.

Some of this is likely because of the narrower selection of default RPM packages that are installed these days when you install F17 and some due to compiling R from source rather than considering using the pre-existing binary R RPM that the Fedora folks provide (eg. sudo yum install R), which would have solved various RPM dependencies upon installation. Of course, the binary would be released versions (eg. 2.15.2) rather than R patched.

BTW Rolf, I don't think that any prior replies have mentioned this, but Fedora specific queries really should be posted over on r-sig-fedora:


That would avail you of a Fedora specific audience, including Fedora/Red Hat maintainers/engineers like Tom Callaway.



More information about the R-help mailing list