[R] new error with QuantMod getSymbols

Adolfo Yanes adolfoyanes at gmail.com
Fri Aug 29 06:12:32 CEST 2014


I use getSymbols function daily to run some models with stock data. Today
when I tried to update the stock info i get this error

Error in charToDate(x) :
  character string is not in a standard unambiguous format

Sometimes I get it after 2 symbols, other times after 150 symbols, another
time after 40 symbols, then after 203 symbols.

The code for the symbol list is:

lista<-read.csv("lista.csv", header=FALSE)


names(lista.list.ana) <- lista[,1]


##actualizar la lista

lista_simbolos<-download_symbols(lista.sum, lista.list.ana)

*The code for the function download_symbols is:*

download_symbols<- function(lista.sum.,lista.list.ana..){

  newnames.<- c("Open", "High", "Low", "Close", "Volume", "Adjusted")

for (m in 1:length(lista.sum.))


print(paste(c("Downloading symbol ", lista.sum.[m], ". ", length(lista.sum.
)-m, " symbols missing"), sep="", collapse=""))








Is it something wrong with yahoo? I tried google and got another error
Error in `colnames<-`(`*tmp*`, value = c("Open", "High", "Low", "Close",  :
  length of 'dimnames' [2] not equal to array extent

Thanks for your help

Adolfo Yanes Musetti

	[[alternative HTML version deleted]]

More information about the R-help mailing list