[R] 'Installation of package <package> had non-zero exit, > status' on R-3.2.0 (RStudio Version 0.98.1103) on Ubuntu 12.04 OS

Prof J C Nash (U30A) nashjc at uottawa.ca
Fri May 1 13:53:11 CEST 2015

As another post has suggested, r-sig-debian may be more help.

However, it looks like you need to install a different package from the
one you tried. See


about getting libcurl on 12.04.

FYI Ubuntu 12.04 is now getting dated, and I've found people using it
get similar problems to that you encountered -- i.e., packages that more
up to date distros use are not available, or those that are available
don't have all the features needed. Maybe time to upgrade.


On 15-05-01 06:00 AM, r-help-request at r-project.org wrote:
> Date: Fri, 1 May 2015 00:50:38 +0530
> From: Anirudh Jayaraman <anirudhj at igidr.ac.in>
> To: Duncan Murdoch <murdoch.duncan at gmail.com>
> Cc: r-help at r-project.org
> Subject: Re: [R] 'Installation of package <package> had non-zero exit
> 	status' on R-3.2.0 (RStudio Version 0.98.1103) on Ubuntu 12.04 OS
> Message-ID:
> 	<CAD4HhLwRUW4jy2XerC4-zvYBDjA8RiPP=82t2k45++mr8jmfpA at mail.gmail.com>
> Content-Type: text/plain; charset="UTF-8"
> In that case, it seems that *libcurl* is not available for R-3.2.0 as I get
> a message for
> *>* *install.packages("libcurl")*
>   package ?libcurl? is not available (for R version 3.2.0)
> Or if on Terminal I run
> *sudo apt-get install libcurl4-openssl-dev*
> Package libcurl4-openssl-dev is not available, but is referred to by
> another package.
> This may mean that the package is missing, has been obsoleted, or
> is only available from another source
> *________________________________________________________*
> *Anirudh Jayaraman*
> M.Sc Economics (2014-16)
> Indira Gandhi Institute of Development Research (IGIDR), Mumbai
> Ph No: +91 9560476729

More information about the R-help mailing list