[R] LaplacesDemon package installation

Rolf Turner r.turner at auckland.ac.nz
Thu Feb 4 22:23:05 CET 2016

(1) You might get better mileage asking this on the r-sig-mac list.

(2) The phenomena you describe are puzzling and are beyond my capacity 
to explain.  Perhaps someone else will be able to enlighten you.

(3) Out of idle curiosity I went to the github site and downloaded the
zip file of the package.  (I could not see a *.tag.gz file, but perhaps 
I just don't understand how github works.  Actually, there's no 
"perhaps" about it!)

I unzipped the download and then did

     R CMD build LaplacesDemon-master

in the appropriate directory.  This created a file


Note that the version number seems to be as you require.

I then used your install.packages syntax, and the package installed 
seamlessly.  It also loaded seamlessly.

So I don't know why the computer gods are picking on you.

Note that I am not working on a Mac, but rather running Linux (as do all 
civilized human beings! :-) )


Rolf Turner

Technical Editor ANZJS
Department of Statistics
University of Auckland
Phone: +64-9-373-7599 ext. 88276

On 05/02/16 06:42, Lluis.Hurtado at uv.es wrote:
> Dear all,
> I've recently changed my Mac and I am trying to reinstall my commonly
> used R-packages. I'm having troubles with a package called
> LaplacesDemon.
> This package is no more in the CRAN list and the developers web page
> (http://www.bayesian-inference.com/software) is out for more than
> half a year. Old versions of the package can still be found in tar.gz
> in
> https://cran.r-project.org/src/contrib/Archive/LaplacesDemon/
> and in github
> https://github.com/ecbrown/LaplacesDemon
> Last version is LaplacesDemon_13.03.04.tar.gz, but I was able to get
> version LaplacesDemon_15.03.19.tar.gz time ago (can't find it
> anymore).
> I have tried to install this packages from source in my computer
> using
>> install.packages("/Users/.../LaplacesDemon_15.03.19.tar.gz", repos
>> = NULL, type="source")
> answer:
>> Warning: invalid package 'Users/.../LaplacesDemon_15.03.19.tar.gz’
>> Error: ERROR: no packages specified Warning message: In
>> install.packages("Users/.../LaplacesDemon_15.03.19.tar.gz",  :
> installation of package ‘Users/.../LaplacesDemon_15.03.19.tar.gz’ had
> non-zero exit status
> I also tried the 'Packages & Data' menu in R, selecting the source
> file or the directory from Finder and I got this message:
>> * installing *source* package ‘LaplacesDemon’ ... ** R ** data **
>> inst ** byte-compile and prepare package for lazy loading ** help
>> *** installing help indices ** building package indices **
>> installing vignettes ** testing if installed package can be loaded
>> * DONE (LaplacesDemon)
> but
>> library(LaplacesDemon)
> Error in library(LaplacesDemon) : there is no package called
> ‘LaplacesDemon’
> Finally I tried
>> install.packages("devtools") library(devtools)
>> install_github("ecbrown/LaplacesDemon")
> but I am not able to install devtools (for similar reasons). So my
> questions are:
> -Do anyone knows how to install this packages in my Mac? -Do anyone
> knows were can I find the information previously content in
> http://www.bayesian-inference.com/software?

More information about the R-help mailing list