[R] [FORGED] Error installing the package "Cairo"

Rolf Turner r.turner at auckland.ac.nz
Mon Feb 15 22:39:10 CET 2016

On 15/02/16 22:51, Sandeep Mallya wrote:
> Hello all,
> I am trying to install the package Cairo on RedHat running R version 3.2.3.
> So far I have tried install.packages("Cairo")
> R CMD INSTALL Cairo_1.5-9.tar.gz
> Both the approaches giving me the same error below.
> Error : .onLoad failed in loadNamespace() for 'Cairo', details:
>    call: dyn.load(file, DLLpath = DLLpath, ...)
>    error: unable to load shared object
> '/home/sandeep/R/x86_64-pc-linux-gnu-library/3.2/Cairo/libs/Cairo.so':
>    libpng15.so.15: cannot open shared object file: No such file or directory
> Error: loading failed
> Execution halted
> Can someone please guide me.

You apparently do not have the "cairo infrastructure" installed on your 
computer.  You probably need to do something like:

sudo yum install cairo.x86_64 # Prob'ly not necessary, this package
                               # should be already there.
sudo yum install cairo-devel.x86_64

You may not need to include the ".x86.64" strings, I'm not sure.  Or you 
may need *not* to include them!



Rolf Turner

Technical Editor ANZJS
Department of Statistics
University of Auckland
Phone: +64-9-373-7599 ext. 88276

More information about the R-help mailing list