[R] Problem with downloading library(Rcmdr)

varin sacha varinsacha at yahoo.fr
Sun Nov 6 14:17:12 CET 2016

Hi Jeff,

Many thanks for your reply.I know that R packages can be downloaded as "tar.gz" file for Mac OS X from CRAN sources. I have found on Internet that the command is the following :

R CMD INSTALL -1 rlme_0.4.tar.gz

When I run that command on my R console, I get an error as you can read here below.

What am I doing wrong ?

> R CMD INSTALL -1 rlme_0.4.tar.gz
Erreur : unexpected symbol in "R CMD"

----- Mail original -----
De : Jeff Newmiller <jdnewmil at dcn.davis.ca.us>
À : varin sacha <varinsacha at yahoo.fr>; varin sacha via R-help <r-help at r-project.org>; David Winsemius <dwinsemius at comcast.net>
Cc : R-help Mailing List <r-help at r-project.org>
Envoyé le : Dimanche 6 novembre 2016 0h07
Objet : Re: [R] Problem with downloading library(Rcmdr)

Google is your friend... try searching for "CRAN rlme".

The bad thing about contributed packages is that sometimes the maintainers stop maintaining their packages. The good thing is that the source is still there so you can go fix it if you really need it. 
Sent from my phone. Please excuse my brevity.

On November 5, 2016 3:33:47 PM PDT, varin sacha via R-help <r-help at r-project.org> wrote:
>Many thanks David,
>My Rcmdr problem is solved but now I have another one with rlme package
>I want to use the hbrwts_gr function from the rlme package.
>I have tried to download the rlme package, but rlme is not available
>(for R version 3.3.2) as you can see here below the error message.
>How can I solve my problem ?
>> install.packages("rlme")
>Installing package into ‘/Users/Caro/Library/R/3.3/library’
>(as ‘lib’ is unspecified)
>Warning in install.packages :
>package ‘rlme’ is not available (for R version 3.3.2)
>De : David Winsemius <dwinsemius at comcast.net>
>Cc : R-help Mailing List <r-help at r-project.org>
>Envoyé le : Samedi 5 novembre 2016 20h42
>Objet : Re: [R] Problem with downloading library(Rcmdr)
>> On Nov 5, 2016, at 11:27 AM, varin sacha via R-help
><r-help at r-project.org> wrote:
>> Dear R-experts,
>> Here below you will find my R sessionInfo. I have a problem with the
>library(Rcmdr). The error message is here below. How can I solve that
>problem ?
>I'm not an Rcmdr user and my Mac is too old to support Sierra so unable
>to attempt replication. All I am able offer is a search on what appear
>to be similar issues in the past. You do need to indicate your XQuartz
>version. I see there have been three recent releases suggesting to me
>that there might have been teething difficulties with the birth of the
>neanate Sierra.
>    • XQuartz 2.7.11 - 2016-10-29
>    • XQuartz 2.7.10 - 2016-10-22
>    • XQuartz 2.7.9 - 2016-05-05
>You might also mention in any follow-up whether this is being done
>inside MacGUI or at an R console launched from Terminal.app.
>Make sure you have reviewed:
>Over the years there have been many questions regarding the three-way
>marriage of R, MacOS, and Rcmdr that relate to Tk/Tcl functions. Here's
>a relatively recent one that mentions the image function:
>So I think I would make sure you have a version of R that has Tcl and
>have the most uptodate X11 version (XQuartz) and once you do that and
>then try to reload R, load Rcmdr _before_ RcmdrMisc and before all
>those other packages. If you still get an error, then repost with
>version details of _all_ the components mentioned to the  R-SIG-Mac
>mailing list and copy John Fox. (Might not be necessary to give him a
>copy since I think he monitors R-SIG-Mac for Rcmdr issues.)
>> Many thanks.
>> sessionInfo()
>> R version 3.3.2 (2016-10-31)
>> Platform: x86_64-apple-darwin13.4.0 (64-bit)
>> Running under: macOS Sierra 10.12
>> locale:
>> [1] fr_CH.UTF-8/fr_CH.UTF-8/fr_CH.UTF-8/C/fr_CH.UTF-8/fr_CH.UTF-8
>> attached base packages:
>> [1] splines   stats     graphics  grDevices utils     datasets 
>methods   base 
>> other attached packages:
>> [1] RcmdrMisc_1.0-5 sandwich_2.3-4  car_2.1-3 
>> loaded via a namespace (and not attached):
>> [1] Rcpp_0.12.7         tcltk2_1.2-11       nloptr_1.0.4      
>RColorBrewer_1.1-2  plyr_1.8.4          class_7.3-14 
>> [7] tools_3.3.2         digest_0.6.10       rpart_4.1-10      
>lme4_1.1-12         gtable_0.2.0        nlme_3.1-128 
>> [13] htmlTable_1.7       lattice_0.20-34     mgcv_1.8-15        
>Matrix_1.2-7.1      parallel_3.3.2      SparseM_1.72 
>> [19] relimp_1.0-5        e1071_1.6-7         gridExtra_2.2.1    
>Rcmdr_2.3-1         stringr_1.1.0       cluster_2.0.5 
>> [25] knitr_1.14          MatrixModels_0.4-1  grid_3.3.2        
>nnet_7.3-12         data.table_1.9.6    tcltk_3.3.2 
>> [31] readxl_0.1.1        survival_2.40-1     foreign_0.8-67    
>latticeExtra_0.6-28 minqa_1.2.4         Formula_1.2-1 
>> [37] ggplot2_2.1.0       magrittr_1.5        htmltools_0.3.5    
>Hmisc_4.0-0         scales_0.4.0        MASS_7.3-45 
>> [43] abind_1.4-5         pbkrtest_0.4-6      colorspace_1.2-7  
>quantreg_5.29       stringi_1.1.2       acepack_1.4.1 
>> [49] munsell_0.4.3       chron_2.3-47        zoo_1.7-13 
>>> library(Rcmdr)
>> Error : .onAttach a échoué dans attachNamespace() pour 'Rcmdr',
>détails :
>> appel : structure(.External(.C_dotTclObjv, objv), class = "tclObj")
>> erreur : [tcl] invalid command name "image".
>> Erreur : le chargement du package ou de l'espace de noms a échoué
>pour 'Rcmdr'
>> ______________________________________________
>> R-help at r-project.org mailing list -- To UNSUBSCRIBE and more, see
>> https://stat.ethz.ch/mailman/listinfo/r-help
>> PLEASE do read the posting guide
>> and provide commented, minimal, self-contained, reproducible code.
>David Winsemius
>Alameda, CA, USA
>R-help at r-project.org mailing list -- To UNSUBSCRIBE and more, see
>PLEASE do read the posting guide
>and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list