[R] Mysterious seg fault --- SOLVED

Rolf Turner r@turner @end|ng |rom @uck|@nd@@c@nz
Wed Aug 15 01:12:00 CEST 2018

On 14/08/18 23:01, peter dalgaard wrote:
> Hmm,
>> .Fortran(stats:::C_setsmu, as.integer(0))
> [[1]]
> [1] 0
>> .Fortran(stats:::C_setsmu, as.integer(fumble))
> Error: object 'fumble' not found
>> .Fortran(stats:::C_setsmu, fumble=as.integer(fumble))
> Error: object 'fumble' not found
>> .Fortran(stats:::C_setsmu, nphi=as.integer(nphi))
> Error: object 'nphi' not found
> so I think we need an alternative hypothesis about what went wrong for you...
> If nphi was NULL from the outset, that could explain things.

No, I never set nphi to NULL.

I put the code back to the way it was previously, just now, and tried 
again. Now I get "object 'nphi' not found".

There is no explanation other than gremlins and the malevolence that the 
computer gods hold towards me.



Technical Editor ANZJS
Department of Statistics
University of Auckland
Phone: +64-9-373-7599 ext. 88276

More information about the R-help mailing list