[R] unable to move temporary installation of package

Paul Lantos paul.lantos at duke.edu
Tue Mar 27 19:14:46 CEST 2018


Here's the error, for example:

> install.packages("mgcv")
Installing package into 'C:/Users/pl39/Documents/R/win-library/3.4'
(as 'lib' is unspecified)
trying URL 'https://mirrors.nics.utk.edu/cran/bin/windows/contrib/3.4/mgcv_1.8-23.zip'
Content type 'application/zip' length 2775362 bytes (2.6 MB)
downloaded 2.6 MB

package 'mgcv' successfully unpacked and MD5 sums checked
Warning in install.packages :
  unable to move temporary installation 'C:\Users\pl39\Documents\R\win-library\3.4\file1f287a90e67\mgcv' to 'C:\Users\pl39\Documents\R\win-library\3.4\mgcv'

The downloaded binary packages are in

> getOption("repos")
                                CRAN                            CRANextra 
"https://mirrors.nics.utk.edu/cran/" "http://www.stats.ox.ac.uk/pub/RWin" 
[1] TRUE

I've used different CRAN mirrors though and gotten the same error.

Would you suggest deleting my personal directory and recreating it? I get the same error if I try and install packages to my documents, my desktop, wherever, so I sort of doubt that would fix the problem.


-----Original Message-----
From: Jeff Newmiller [mailto:jdnewmil at dcn.davis.ca.us] 
Sent: Tuesday, March 27, 2018 1:14 PM
To: Paul Lantos <paul.lantos at duke.edu>
Cc: r-help at r-project.org
Subject: RE: [R] unable to move temporary installation of package

Nothing jumps out at me yet.

1) You missed including the text of your command (presumably
install.packages) along with the actual text of the error.

2) What is the output of:


3) You might also consider looking at

system2( "cacls.exe", .libPaths()[1] )

though we may not be able to interpret the output appropriately in this venue if you are working on a managed computer... you might need local help. I would guess you would need "yourdomain\youruser:(OI)(CI)F".

Note that your personal R library is not deleted when you uninstall R... 
if you have not yet deleted C:\Users\pl39\Documents\R\win-library\3.4
and let R re-create it then uninstalling would not have helped a permissions problem.

On Tue, 27 Mar 2018, Paul Lantos wrote:

> Ok, thanks --
>> sessionInfo()
> R version 3.4.4 (2018-03-15)
> Platform: x86_64-w64-mingw32/x64 (64-bit) Running under: Windows >= 8 
> x64 (build 9200)
> Matrix products: default
> locale:
> [1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United 
> States.1252 [3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C 
> [5] LC_TIME=English_United States.1252
> attached base packages:
> [1] stats     graphics  grDevices utils     datasets  methods   base
> loaded via a namespace (and not attached):
> [1] compiler_3.4.4 tools_3.4.4    yaml_2.1.14
>> .libPaths()
> [1] "C:/Users/pl39/Documents/R/win-library/3.4" "C:/Program Files/R/R-3.4.4/library"
>> file.info(.libPaths())
>                                          size isdir mode               mtime               ctime               atime
> C:/Users/pl39/Documents/R/win-library/3.4    0  TRUE  777 2018-03-27 10:21:39 2017-12-28 22:20:55 2018-03-27 10:21:39
> C:/Program Files/R/R-3.4.4/library           0  TRUE  777 2018-03-25 21:23:45 2018-03-25 21:23:08 2018-03-25 21:23:45
>                                          exe
> C:/Users/pl39/Documents/R/win-library/3.4  no
> C:/Program Files/R/R-3.4.4/library         no
> -----Original Message-----
> From: Jeff Newmiller [mailto:jdnewmil at dcn.davis.ca.us]
> Sent: Tuesday, March 27, 2018 1:16 AM
> To: Paul Lantos <paul.lantos at duke.edu>; r-help at r-project.org
> Subject: RE: [R] unable to move temporary installation of package
> Perhaps someone here will see something useful if you post the output of the following function calls:
> sessionInfo()
> .libPaths()
> file.info(.libPaths())
> and the verbatim (copied) error (in context) that you are seeing.
> --
> Sent from my phone. Please excuse my brevity.
> On March 26, 2018 6:27:10 PM PDT, Paul Lantos <paul.lantos at duke.edu> wrote:
>> Thanks Jeff,
>> So I initially when I got the computer moved my old packages into the 
>> new directory rather than downloading and installing them again. That 
>> was fine. I then just did a test to see if I could write in the 
>> folder and indeed I can. Just not via R.
>> I uninstalled R Open, installed R 3.4.4, and the problem persisted, 
>> including just running it from the R console rather than from R Studio.
>> I haven't done anything (like installations) with administrator 
>> rights
>> - I just have them. That said I've checked the permissions of the 
>> library folder and I have all permission. I don't run R in any 
>> special way.
>> So I'm not sure where that leaves me... thanks for any suggestions.
>> Paul
>> -----Original Message-----
>> From: Jeff Newmiller [mailto:jdnewmil at dcn.davis.ca.us]
>> Sent: Monday, March 26, 2018 5:22 PM
>> To: r-help at r-project.org; Paul Lantos <paul.lantos at duke.edu>; 
>> r-help at r-project.org
>> Subject: Re: [R] unable to move temporary installation of package
>> A) Don't try to "move" packages from one library (=directory of 
>> installed packages) to another.
>> B) Although R Open is very close to CRAN R, it has some differences 
>> that you REALLY NEED TO READ about at their website. Pay particular 
>> attention to the checkpoint feature in this case. Note that troubles 
>> installing it or with the MKL are probably off-topic here, though R 
>> language questions should still be fair game.
>> C) Having Administrator rights carries at least as much 
>> responsibility to know what you are doing BEFORE you do it as it 
>> bestows flexibility to get things done. If you used "Run As 
>> Administrator" to install R or any packages then you have probably 
>> set the permissions on your personal library inappropriately. If so, 
>> you need to use your superpowers judiciously to eliminate your 
>> personal library completely and then run R as a normal user to install/update R packages.
>> --
>> Sent from my phone. Please excuse my brevity.
>> On March 26, 2018 12:16:02 PM PDT, Paul Lantos <paul.lantos at duke.edu>
>> wrote:
>>> I'm running Windows 10 / R Studio / R Open 3.4.3
>>> Since getting a new computer recently I cannot install packages into
>> my
>>> personal libpath directory, and I can't seem to update packages (it 
>>> says all packages are up to date even if I manually install an old 
>>> version). I've got 100% admin rights on the computer and in the
>> library
>>> folder, I've set my R environment variable to specify the correct 
>>> directory, I can freely move things manually in and out of the 
>>> library
>>> if needed, and R can read and use any package that's already in there.
>>> But I can't install or I get the "unable to move" error.
>>> I've uninstalled and reinstalled everything, tried this in 
>>> non-Studio sessions using both R Open and regular R 3.4.4, and I get 
>>> the same error.
>>> Thanks for any help,
>>> Paul Lantos
>>> _____________________________________________
>>> Paul M. Lantos, MD, MS GIS, FIDSA, FAAP, FACP Associate Professor of 
>>> Internal Medicine and Pediatrics  Pediatric Infectious Diseases  
>>> General Internal Medicine Duke University School of Medicine Duke 
>>> Global Health Institute 
>>> _____________________________________________
>>> 	[[alternative HTML version deleted]]
>>> ______________________________________________
>>> R-help at r-project.org mailing list -- To UNSUBSCRIBE and more, see
>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__stat.ethz.ch_mail
>>> m
>>> an_listinfo_r-2Dhelp&d=DwIFaQ&c=imBPVzF25OnBgGmVOlcsiEgHoG1i6YHLR0Sj_g
>>> Z
>>> 4adc&r=pCiIbVPBNWU0azo0D48ChUH_fawb-FalNVOf1sUn1r4&m=twuFRS-tVJfQuRzjI
>>> S
>>> 0GBC710QPtmpe1rDy5PNvS-GI&s=OtjN9-16IbB6IqUW1THCx-YX8wccZgBEQmfZY6cuBI
>>> I
>>> &e=
>>> PLEASE do read the posting guide
>>> https://urldefense.proofpoint.com/v2/url?u=http-3A__www.R-2Dproject.or
>>> g
>>> _posting-2Dguide.html&d=DwIFaQ&c=imBPVzF25OnBgGmVOlcsiEgHoG1i6YHLR0Sj_
>>> g
>>> Z4adc&r=pCiIbVPBNWU0azo0D48ChUH_fawb-FalNVOf1sUn1r4&m=twuFRS-tVJfQuRzj
>>> I
>>> S0GBC710QPtmpe1rDy5PNvS-GI&s=sY7Wm-L9iESeuqa2CevDBwLsBx06RewTYq2-DFg9K
>>> M U&e= and provide commented, minimal, self-contained, reproducible
>> code.

Jeff Newmiller                        The     .....       .....  Go Live...
DCN:<jdnewmil at dcn.davis.ca.us>        Basics: ##.#.       ##.#.  Live Go...
                                       Live:   OO#.. Dead: OO#..  Playing
Research Engineer (Solar/Batteries            O.O#.       #.O#.  with
/Software/Embedded Controllers)               .OO#.       .OO#.  rocks...1k

More information about the R-help mailing list