[R] [R-sig-Debian] 3.6 on debian stretch
joh@nne@@r@nke @end|ng |rom jrwb@de
Thu Aug 1 08:49:58 CEST 2019
yes, because of various factors the r-cran-* packages from the stable and
especially the oldstable distribution are often not compatible with the
backported r-base packages provided on CRAN. At current, buster is not
affected, but your case shows that using stretch gives this problem.
In principle it would be nice to have a repo containing all the r-cran-* and
r-bioc-* packages recompiled for these backports. Such a repository does exist
for Ubuntu as far as I know (I don't use it). For Debian, such a repository
currently does not exist.
In your situation, I think the easiest solution is to simply install caret and
ggplot2 from within R.
Personally, I like the install.r and update.r scripts available from Dirks
littler package. They make it possible to conveniently install and update R
packages from source using the command line, if you have the scripts in your
Am Mittwoch, 31. Juli 2019, 21:41:14 CEST schrieb Larry Martell:
> I need to run 3.6 on debian stretch - I followed the instructions here:
> and I was able to install it. But 2 packages I need, r-cran-caret and
> r-cran-ggplot2 will not install:
> # apt-get install r-cran-ggplot2
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
> r-cran-ggplot2 : Depends: r-api-3
> Depends: r-cran-digest but it is not going to be installed
> Depends: r-cran-gtable (>= 0.1.1) but it is not
> going to be installed
> Depends: r-cran-plyr (>= 1.7.1) but it is not going
> to be installed
> Depends: r-cran-reshape2 but it is not going to be
> installed Depends: r-cran-scales (>= 0.4.1) but it is not
> going to be installed
> Depends: r-cran-tibble but it is not going to be installed
> Depends: r-cran-lazyeval but it is not going to be installed E: Unable to
> correct problems, you have held broken packages.
> Is there a way to get these 2 packages for my environment?
> R-SIG-Debian mailing list
> R-SIG-Debian using r-project.org
More information about the R-help