[R] Using older version of R

Duncan Murdoch murdoch@dunc@n @end|ng |rom gm@||@com
Fri Dec 20 18:17:58 CET 2019

On 20/12/2019 11:24 a.m., Steven Yen wrote:
> I had to use an older version of R (as old as R3.0.3) for a reason. I
> myself have no problem installing a package built under a newer version,
> but my student (who also installed R3.0.3) could not install the package
> (newer version). Had an error message saying package xxxxx is not
> available under R3.0.3. Is there a get-arround----to be able to install
> while running an older R version? (Don't ask me why I run an older R. An
> essential package I need works well only in R3.0.3). Thank you all.

CRAN doesn't make binaries of packages available for ancient versions, 
so you'll need to build each package yourself.  That's easy for packages 
without compiled code (C, Fortran, C++), but harder with it.

If you are using Windows, you will need to install Rtools; that version 
of R will need an older version of ịt (I think 3.0 or 3.1 should work). 
If you are on some other platform, it's possible you may need an older 
version of the compilers for that platform.

The other issue is that many packages depend on recent features of R, 
but don't state the dependency (because the author didn't notice it). 
This means you may need to go to the CRAN archives for older versions of 
some packages.  One approach is to use Microsoft's daily CRAN snapshots 
and get everything that was current in the past, but even they don't go 
back to March 2014 when 3.0.3 was current.

Duncan Murdoch

More information about the R-help mailing list