[BioC] getBioC problem: reposTools

James Wettenhall wettenhall at wehi.edu.au
Mon Mar 10 13:00:31 MET 2003


I tried to install Bioconductor (1.1) in R for windows version 
1.6.2, using getBioC(), but I got the following error message:

> getBioC()
Running getBioC version 1.2.19....
If you encounter problems, first make sure that
you are running the latest version of getBioC()
which can be found at: www.bioconductor.org/getBioC.R

Please direct any concerns or questions to 
bioconductor at stat.math.ethz.ch.

[1] "Getting/installing packages reposTools and Biobase"
Error in upDatePkgs(repository, PLATFORM, isDevel, version, 
        Could not get the required package - reposTools

I have tried quite a few other variations, like 
getBioC("all",force=TRUE), but
they didn't make any difference.  

I notice on the Bioconductor website, that there is no Win32 
binary package for reposTools available to donwload.  I could 
download the source, run Rcmd build and then try "Install 
Package from ZIP file" in R, but surely this shouldn't be 

Last time I installed Bioconductor (for R 1.6.1), I just 
downloaded each ZIP file individually and did "install from 
ZIP", which seemd to work OK. So it's tempting to just copy the 
Bioconductor subdirectories across from the library 
subdirectory of my R 1.6.1 installation (which I still have), 
but obviously it would be nicer to be able install them with 
getBioC() or equivalent.


James Wettenhall                                  Tel: (+61 3) 9345 2629
Division of Genetics and Bioinformatics           Fax: (+61 3) 9347 0852
The Walter & Eliza Hall Institute         E-mail: wettenhall at wehi.edu.au
 of Medical Research,                     Mobile: (+61 / 0 ) 438 527 921    
1G Royal Parade,
Parkville, Vic 3050, Australia

More information about the Bioconductor mailing list