[BioC] error from library(affy)

Yasushi Okubo yokubo at acm.org
Sat Nov 1 20:27:15 MET 2003

Please advise me how to fix this problem.

I loaded R - 1.8.0 to my pc (Windows 2000)
then ran 

from R window, I typed :

then I got :
> library(affy)
Welcome to Bioconductor 
         Vignettes contain introductory material.  To view, 
         simply type: openVignette() 
         For details on reading vignettes, see
         the openVignette help page.
Error in setMethod("sampleNames", "Cel", function(object) object at name,  : 
        No existing definition for function "sampleNames"
Error in library(affy) : .First.lib failed

So, I tried to update pacakages:

Then I ran again, but got the following error.
> library(affy)
Error in bindingIsLocked(m1, where) : not an environment
Error in setClass("AffyBatch", representation(cdfName = "character", nrow = "numeric",  : 
        Error in contained classes ("exprSet") for class "AffyBatch"; class definition removed from "affy"
Error in library(affy) : .First.lib failed

Can someone tell what is wrong?  It looks like I should not update package, but it still had an error in setMethod function.


	[[alternative HTML version deleted]]

More information about the Bioconductor mailing list