[BioC] Querying PubMed Database

Vincent Carey 525-2265 stvjc at channing.harvard.edu
Thu Sep 25 17:29:04 MEST 2003

> I am very interested to query PubMed using Bioconductor.
> I can load annotate, affy, affydata without trouble.
> I've run RMA on data sets without problems. For some
> reason, I am running into trouble when trying to
> follow the instructions in "HowTo:Automated Querying
> of PubMed Data".
> I can't load hgu95av2. That library is "not found".
> > library(hgu95av2)
> Error in library(hgu95av2) : There is no package called 'hgu95av2'
> Since this is the case, I downloaded it from Bioconductor
> and installed it in my working directory using
> R CMD INSTALL -l "." hgu95av2_1.3.1.tar.gz

what operating system are you using?  presumably a *nix.
what version of R?

> It seemed to install just fine, but when I try to read it
> into R using library(hgu95av2, lib.loc=".") and various
> permutations of that command, the library is still not found.
> I tried to get around this by sourcing in the hgu95av2 file
> that is in local/hgu95av2/R...This did not work either.

but if you installed it in ".", why would you look in "local/hgu95av2"?
where is the 'local' coming from?

> Any suggestions ?

never try to install R package resources except by the R
package handling mechanisms, unless you are very sure of
what you are doing.  you could use reposTools and install.packages2,
or you can obtain the tar.gz file and run the install command

since it appears that you do not have write access to the central
R library (because you are using INSTALL -l) you may want to talk
to your administrators about having them install the bioconductor
resources for central use.  if you do run your own version of R,
install.packages2 is the easiest way to get new packages installed.

More information about the Bioconductor mailing list