[BioC] recipe for installing and using Bioconductor with Mac OS X 10.3 and R GUI 1.9

Marc Salit salit at nist.gov
Thu Apr 22 00:43:54 CEST 2004

Dear Colleagues --

A little follow-up is in order -- I've got things going, more or less. 
Mostly more. Thanks for the suggestions, which mostly got me on track.  
Bioconductor things seem to work in general, it was the affy package I 
was having trouble with. I am still having problems with the 'widget' 
tools, but have received some leads on that (problems with tcltk).

Ok, so I'm running R release version Version 1.9.0  (2004-04-12) , on 
Mac OS X 10.3.3 on a PowerMac G5 2.0 GHz dual processor.

Some things that I did in order to get going:
	1) I installed the Apple Mac OSX developer's tools, which are needed 
to compile source.

	2) I changed owner and permissions on the R.Framework directory, and 
everything underneath it to permit r/w access to all users. (From some 
of the error messages I was receiving, it seemed that this was 
necessary, though your mileage may vary...)

	3) I downloaded the development version of the affy package 
(affy_1.4.23.tar.gz) and installed from the command line. The 
'released' version (affy_1.3.28.tar.gz) would not install this way, it 
died while building help for normalize.invariantset (see below).

   normalize.contrast                text    html    latex   example
   normalize.invariantset            text    html    latex

ERROR: command (e.g. \url) inside \link
ERROR: building help failed for package 'affy'
** Removing 

And, my problems with tcltk:

 > package.manager()
loading package: widgetTools
Loading required package: tcltk
Error in fun(...) : this isn't a Tk applicationcouldn't connect to 
display ":0"
Error: .onLoad failed in loadNamespace
Error in f(libname, pkgname) : Package tcltk not able to be loaded!
Error in library(pkgs[i], character.only = TRUE) :
	.First.lib failed
 > dchip <- expresso(widget=TRUE)
Loading required package: tkWidgets
Error in expresso(widget = TRUE) : library tkWidgets could not be found 
In addition: Warning message:
There is no package called 'tkWidgets' in: library(package, 
character.only = TRUE, logical = TRUE, warn.conflicts = warn.conflicts,
 > package.manager()
loading package: tcltk
Error in fun(...) : this isn't a Tk applicationcouldn't connect to 
display ":0"
Error: .onLoad failed in loadNamespace
Error in library(pkgs[i], character.only = TRUE) :
	package/namespace load failed

Best regards,
Marc Salit

On Apr 13, 2004, at 5:15 PM, Marc Salit wrote:

> Dear Colleagues --
> I've been trying unsuccessfully to use Bioconductor (mostly the affy 
> package) on a Mac with OS X 10.3.3, running R with a GUI, either 1.8.1 
> or 1.9.0 beta. I've tried to install Bioconductor with getBioC.R, 
> which doesn't work all the way, and also tried to use a shell command 
> to install downloaded packages, a la R CMD INSTALL 
> /path/to/pkg_version.tar.gz , which also doesn't work all the way 
> (stops when it can't find a 'make' command in SHLIB.
> Suggestions? Caveats? Will this work? Shall I give up and 'switch' 
> back to a PC???
> Cheers & TIA,
> Marc Salit
> -- 
> Dr. Marc Salit
> Research Chemist
> Chemical Science and Technology Laboratory
> 100 Bureau Drive, Stop 8391
> Gaithersburg, MD 20899-8391
> email: Salit at NIST.gov
> voice: +1 301 975-3646
> fax:   +1 301 869-0413_______________________________________________
> Bioconductor mailing list
> Bioconductor at stat.math.ethz.ch
> https://www.stat.math.ethz.ch/mailman/listinfo/bioconductor
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: text/enriched
Size: 3825 bytes
Desc: not available
Url : https://www.stat.math.ethz.ch/pipermail/bioconductor/attachments/20040421/54479d8c/attachment-0001.bin

More information about the Bioconductor mailing list