[BioC] Mising data

Alex F. Bokov yjih74b02 at sneakemail.com
Thu Feb 19 19:05:55 MET 2004

Dear Ms. Gu:

The following message appears to be in reference to a problem similar to 
the one you're having.


Note that the author of that message seems to be running an older 
version of R. If that's not your problem, then doing the thing he tried 
might work for you-- namely invoking R with the --max-mem-size=1024M 
command-line flag.

Alternatively, you can set the memory limit from inside of R with this 
command: memory.limit(size=1024)

By the way, how much RAM do you have in your computer and how large is 
the swap-file?

>I am using marrayClasses package to read my raw data into R.
>I have 89 arrays, I put them in the same directory, and read them all. but I got the following error messages, 
>Error: cannot allocate vector of size 3828 Kb
>What is the maximum size marray package can handle to read into R?

I suspect this error message indicates that R is incorrectly parsing the 
number of rows and columns. How many rows and columns does it report 
reading? Do they match what's supposed to be in your data? I don't know 
about this particular package, but when I have this problem reading 
tabular data in general, changing the column names and row names so they 
contain no spaces usually fixes it.

>Also,I tried to read one file at a time, I got the following messages,
>Warning messages: 
>1: number of items read is not a multiple of the number of columns 
>2: NAs introduced by coercion 
>3: NAs introduced by coercion 
>4: NAs introduced by coercion 
>5: NAs introduced by coercion

                               --Sincerely, Alex F. Bokov
                                 Department of Physiology
"Dealing with failure is easy: Work hard to improve. Success 
is also easy to handle: You've solved the wrong problem. 
Work hard to improve."         - Alan Perlis

More information about the Bioconductor mailing list