[BioC] pExplorer bug?

James Wettenhall wettenhall at wehi.edu.au
Fri Jun 4 04:11:13 CEST 2004

Hi Fai,

pExplorer() uses Tcl/Tk, and there probably aren't too many 
people on this mailing list who have tried using Tcl/Tk with 
a non-english character set (I suppose this requires a 
version of Tcl/Tk configured to use Unicode).

If, after isolating the problem further, it turns out 
to be related to TclTk/UniCode, then maybe it could be 
reported to a Tcl/Tk mailing list.

John Zhang (author of tkWidgets, including pExplorer) may have 
ideas about why pExplorer might not work on your system.  I 
just tried pExplorer(), and on my system (Windows 2000 
(English), R 1.9.0, tkWidgets 1.3.20), clicking the drop-down 
button seems to give the expected listbox (simulating a 
drop-down combo-box), but then (after selecting an item from 
the simulated drop-down combo-box), pExplorer seems to freeze 
quite easily (maybe a problem with tkgrab or something similar).  


James Wettenhall                                  Tel: (+61 3) 9345 2629
Division of Genetics and Bioinformatics           Fax: (+61 3) 9347 0852
The Walter & Eliza Hall Institute         E-mail: wettenhall at wehi.edu.au
 of Medical Research,                     Mobile: (+61 / 0 ) 438 527 921    
1G Royal Parade,
Parkville, Vic 3050, Australia

More information about the Bioconductor mailing list