[BioC] memory problem with fitPLM in package affyPLM

fhong at salk.edu fhong at salk.edu
Thu Jun 9 19:22:29 CEST 2005

Sorry to bring such an old question up again. I hope that somebody can
explain what is happening here.

I tried to run fitPLM to about 72 affy ATH1 arrays. It worked with affyPLM
version 1.2.5 under R2.0.1, then I saved it as "dataPLM.RData" with option
Later when I reload "dataPLM.RData" into working space (R2.1.0) and try to
run boxplot and Mbox, it told me that

" Error in if (object at model.description$R.model$which.parameter.types[3] ==
        argument is of length zero
 since object at model.description is NULL."

How did this happen? Does "compress=TRUE" destroy some of the internal
structure of PLMset object?

then I tried to run fitPLM again ( on the affyBatch object I saved before)
using package affyPLM version 1.3.3 under R2.1.0 But this time it wouldn't
finish (after Background correcting PM, Normalizing PM)
 but generated an error of R and closed R after that. I thought that may
because my laptop has only 1.5Gb memory.
Does this mean that there is some substantial change of affyPLM package
between version 1.3.3 and version 1.2.5?

I then tried to run this using a Linux machine with 4Gb accessible memory
size (there is no limitation in memory for each user and I reboot the
system as a super user). But I still got the error message about memory,

> Pset.Goda=fitPLM(data.Goda.I)
Background correcting PM
Normalizing PM
Fitting models
Error: cannot allocate vector of size 52 Kb

Does this mean 4Gb is still not enough?

My last question is what I need to update my computer in order to analyze
72 arrays together (simpleaffy, affyPLM,Limma...)

Thank you very much, any suggestion will be highly appreciated!

Fangxin Hong  Ph.D.
Plant Biology Laboratory
The Salk Institute
10010 N. Torrey Pines Rd.
La Jolla, CA 92037
E-mail: fhong at salk.edu
(Phone): 858-453-4100 ext 1105

More information about the Bioconductor mailing list