[BioC] memory problem with fitPLM in package affyPLM

Ben Bolstad bolstad at stat.berkeley.edu
Thu Jun 9 19:40:56 CEST 2005

There were significant changes in the structure of the PLMset object
between 1.2.x and 1.3.x which is why you are having problems with the
boxplot(), Mbox() commands on your old PLMset using the new code.

To reduce memory usage with fitPLM I suggest that you do something like
the following

Pset <- fitPLM(my.Data,output.param=list(varcov="none"))

which should significantly reduce memory usage (and this should really
be the default setting, an oversight on my part which will be fixed

Also, if you can live without the weights (or alternatively the
residuals) you could do
Pset <- fitPLM(my.Data,output.param=list(varcov="none",weights=FALSE))


Pset <- fitPLM(my.Data,output.param=list(varcov="none",residuals=FALSE))

which would also reduce the memory overhead.


On Thu, 2005-06-09 at 10:22 -0700, fhong at salk.edu wrote:
> Sorry to bring such an old question up again. I hope that somebody can
> explain what is happening here.
> (1)
> I tried to run fitPLM to about 72 affy ATH1 arrays. It worked with affyPLM
> version 1.2.5 under R2.0.1, then I saved it as "dataPLM.RData" with option
> "compress=TRUE"
> Later when I reload "dataPLM.RData" into working space (R2.1.0) and try to
> run boxplot and Mbox, it told me that
> " Error in if (object at model.description$R.model$which.parameter.types[3] ==
> :
>         argument is of length zero
>  since object at model.description is NULL."
> How did this happen? Does "compress=TRUE" destroy some of the internal
> structure of PLMset object?
> (2)
> then I tried to run fitPLM again ( on the affyBatch object I saved before)
> using package affyPLM version 1.3.3 under R2.1.0 But this time it wouldn't
> finish (after Background correcting PM, Normalizing PM)
>  but generated an error of R and closed R after that. I thought that may
> because my laptop has only 1.5Gb memory.
> Does this mean that there is some substantial change of affyPLM package
> between version 1.3.3 and version 1.2.5?
> I then tried to run this using a Linux machine with 4Gb accessible memory
> size (there is no limitation in memory for each user and I reboot the
> system as a super user). But I still got the error message about memory,
> saying
> > Pset.Goda=fitPLM(data.Goda.I)
> Background correcting PM
> Normalizing PM
> Fitting models
> Error: cannot allocate vector of size 52 Kb
> Does this mean 4Gb is still not enough?
> My last question is what I need to update my computer in order to analyze
> 72 arrays together (simpleaffy, affyPLM,Limma...)
> Thank you very much, any suggestion will be highly appreciated!
> Fangxin
> --------------------
> Fangxin Hong  Ph.D.
> Plant Biology Laboratory
> The Salk Institute
> 10010 N. Torrey Pines Rd.
> La Jolla, CA 92037
> E-mail: fhong at salk.edu
> (Phone): 858-453-4100 ext 1105
> _______________________________________________
> Bioconductor mailing list
> Bioconductor at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/bioconductor
Ben Bolstad <bolstad at stat.berkeley.edu>

More information about the Bioconductor mailing list