[BioC] unable to re-install after interupted installation

Adaikalavan Ramasamy ramasamy at cancer.org.uk
Sat Mar 12 05:32:41 CET 2005

Dear Seth,

Many thanks for your informative suggestion. I think I solved the
problem by following Jeff Gentry's suggestion as follows

 all <- CRAN.packages(CRAN=getOption("BIOC")) 
 install.packages( all, CRAN=getOption("BIOC") )

I am not sure why it worked at all but am just glad it did. I still
cannot fully appreciate the need to source the installation script from
the web when it could be called directly from R.

I thought about your suggestion about wiping out only BioConductor
packages but was too lazy to identify them one by one. It would have
been a lot easier if R packages were installed in $R_HOME/lib/R/library
and BioConductor packages in $R_HOME/lib/BioC/library . If another
significant user group like BioConductor comes along, it would make it
easier to expand the current R directory structure.

Anyway I am sure the BioConductor core have their reasons.

Thank you again.

Regards, Adai

On Fri, 2005-03-11 at 07:49 -0800, Seth Falcon wrote:
> Hi there,
> I've just tried what you tried on one of our Linux systems using
> R-patched.  
> >> source("http://www.bioconductor.org/getBioC.R")
> >> getBioC(libName="all")
> It is still installing, but GO at version 1.7.0 installed fine (not
> the version change which explains the missing URL).
> Adaikalavan Ramasamy <ramasamy at cancer.org.uk> writes:
> > While installing all BioConductor packages, my laptop crashed
> > (forgot to plug it in the power socket). Ever since that, I have not
> > been unable to re-install all the packages.
> I have a hunch that the problem is that your first install attempt
> occured before a site update and so you have some packages installed
> that are stale.  Here are two suggestions to try to fix this:
> 1. Clean out your library directory of all Bioconductor packages.
>    Since it looks from your mail that you installed to the default
>    package library, you need to be careful not to remove everything,
>    just things that came from Bioconductor.
> 2. Try installing to a non-default package library.  You can do this
>    as follows:
>    1. Before starting R, set the R_LIBS environment variable:
>         mkdir bioc-pkg-lib
>         export R_LIBS=bioc-pkg-lib
>         R
>    2.  Run getBioC as you did before.  You will be given an option to
>        install into bioc-pkg-lib.   
> Let us know if this helps or if the problem persists.
> Thanks,
> + seth

More information about the Bioconductor mailing list