[BioC] unable to re-install after interupted installation

Seth Falcon sfalcon at fhcrc.org
Fri Mar 11 16:49:53 CET 2005

Hi there,

I've just tried what you tried on one of our Linux systems using

>> source("http://www.bioconductor.org/getBioC.R")
>> getBioC(libName="all")

It is still installing, but GO at version 1.7.0 installed fine (not
the version change which explains the missing URL).

Adaikalavan Ramasamy <ramasamy at cancer.org.uk> writes:
> While installing all BioConductor packages, my laptop crashed
> (forgot to plug it in the power socket). Ever since that, I have not
> been unable to re-install all the packages.

I have a hunch that the problem is that your first install attempt
occured before a site update and so you have some packages installed
that are stale.  Here are two suggestions to try to fix this:

1. Clean out your library directory of all Bioconductor packages.
   Since it looks from your mail that you installed to the default
   package library, you need to be careful not to remove everything,
   just things that came from Bioconductor.

2. Try installing to a non-default package library.  You can do this
   as follows:

   1. Before starting R, set the R_LIBS environment variable:

        mkdir bioc-pkg-lib
        export R_LIBS=bioc-pkg-lib

   2.  Run getBioC as you did before.  You will be given an option to
       install into bioc-pkg-lib.   

Let us know if this helps or if the problem persists.


+ seth

More information about the Bioconductor mailing list