[BioC] Problem loading RdbiPgSQL

Thomas Adams Thomas.Adams at noaa.gov
Mon May 7 16:11:45 CEST 2007

Sean & Seth,

Thanks so much for your help and good suggestions. Unfortunately, none 
worked. I even went so far as to install R 2.5.0 and PostgreSQL 8.2.4 
(into a local directory)…

One interesting point, is that when I install RdbiPgSQL 1.8, the install 
script is still looking for the include file libpq-fe.h in /usr/include 
even though I have specified the PostgreSQL 8.2.4 libraries & includes 
elsewhere using:

--configure-args='--with-pgsql-libraries=/local-path/lib --with-pgsql-includes=/local-path/include' \

xt4-tir:adams> b --with-pgsql-includes=/usr/include' 
RdbiPgSQL_1.8.0.tar.gz <
Loading Tcl/Tk interface ... done
* Installing to library '/awips/rep/lx/local_apps/R/lib/R/library'
* Installing *source* package 'RdbiPgSQL' ...
creating cache ./config.cache
checking how to run the C preprocessor... cc -E
checking for /usr/include/libpq-fe.h... yes
updating cache ./config.cache
creating ./config.status
creating src/Makevars
** libs
gcc -std=gnu99 -I/awips/rep/lx/local_apps/R/lib/R/include 
-I/awips/rep/lx/local_apps/proj4/include -I/usr/local/include -fpic -g 
-O2 -c PgSQL.c -o PgSQL.o
gcc -std=gnu99 -I/awips/rep/lx/local_apps/R/lib/R/include 
-I/awips/rep/lx/local_apps/proj4/include -I/usr/local/include -fpic -g 
-O2 -c PgSQLInit.c -o PgSQLInit.o
gcc -std=gnu99 -shared -L/usr/local/lib -o RdbiPgSQL.so PgSQL.o 
PgSQLInit.o -L/awips/rep/lx/local_apps/proj4/lib
** R
** help
 >>> Building/Updating help pages for package 'RdbiPgSQL'
Formats: text html latex example
PgSQL text html latex
dbAppendTable.PgSQL.conn text html latex
dbClearResult.PgSQL.result text html latex
dbColumnInfo.PgSQL.result text html latex
dbConnect.PgSQL text html latex
dbConnectionInfo.PgSQL.conn text html latex
dbDisconnect.PgSQL.conn text html latex
dbGetQuery.PgSQL.conn text html latex
dbGetResult.PgSQL.result text html latex
dbListTables.PgSQL.conn text html latex
dbReadTable.PgSQL.conn text html latex
dbResultInfo.PgSQL.result text html latex
dbSendQuery.PgSQL.conn text html latex
dbWriteTable.PgSQL.conn text html latex
internal text html latex
psql text html latex
** building package indices ...
* DONE (RdbiPgSQL)

This is getting very frustrating, because I do not have problems 
installing any other packages from source. Previously, about 1-year ago, 
I installed a package Rdbi.PgSQL, which worked fine with R 2.2.x. 
However, we have undergone a couple of Redhat system upgrades as well as 
going from IBM to (now) HP hardware, and a couple R updates. So, there 
are many confounding issues…


Sean Davis wrote:
> Seth Falcon wrote:
>> Hi Thomas,
>> Thomas Adams <Thomas.Adams at noaa.gov> writes:
>>> Following your suggestion, I get:
>>> from a Linux prompt:
>>> ldd
>>> /awips/rep/lx/local_apps/R/lib/R/library/RdbiPgSQL/libs/RdbiPgSQL.so
>>> produces:
>>>        libc.so.6 => /lib/tls/libc.so.6 (0x00329000)
>>>        /lib/ld-linux.so.2 (0x00a17000)
>> This is quite strange and very different from what I get on one of our
>> Linux servers.
>> ldd RLIBS/2.5/RdbiPgSQL/libs/RdbiPgSQL.so 
>>         libpq.so.4 => /usr/lib64/libpq.so.4 (0x00002aaaaabd3000)
>>         libc.so.6 => /lib64/tls/libc.so.6 (0x00002aaaaacf5000)
>>         libssl.so.0.9.7 => /usr/lib64/libssl.so.0.9.7 (0x00002aaaaaf20000)
>>         libcrypto.so.0.9.7 => /usr/lib64/libcrypto.so.0.9.7 (0x00002aaaab057000)
>>         libkrb5.so.3 => /usr/lib64/libkrb5.so.3 (0x00002aaaab28f000)
>>         libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00002aaaab407000)
>>         libresolv.so.2 => /lib64/libresolv.so.2 (0x00002aaaab541000)
>>         libnsl.so.1 => /lib64/libnsl.so.1 (0x00002aaaab655000)
>>         libpthread.so.0 => /lib64/tls/libpthread.so.0 (0x00002aaaab76b000)
>>         /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)
>>         libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaab881000)
>>         libk5crypto.so.3 => /usr/lib64/libk5crypto.so.3 (0x00002aaaab984000)
>>         libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00002aaaabaa8000)
>>         libkrb5support.so.0 => /usr/lib64/libkrb5support.so.0 (0x00002aaaabbab000)
>> In particular, the fact that your .so file doesn't link to libpq.so
>> explains why you get the error message about PQfsize being missing.
>> So now you need to figure out why you are ending up with an
>> RdbiPgSQL.so that is not linked to libpq.
>> You said that you found the PostgreSQL include files in /usr/include.
>> Can you check that you also have libpq.so.* in /usr/lib?  If so, have
>> you tried:
>>  --configure-args='--with-pgsql-libraries=/usr/lib --with-pgsql-libraries=/usr/include' \
>>  RdbiPgSQL_1.8.0.tar.gz
> And if that doesn't work, I would suggest installing postgresql from 
> source into your home directory (or some other directory to which you 
> have access) and try the same (with appropriate lib and include 
> directories (note that the above should have 
> --with-pgsql-includes=/usr/include, I think).  We have not had trouble 
> on either MacOS or linux with doing so.  There is no need to run or even 
> set up the installed version of postgresql, just link to its libraries.  
> The compatibility between various versions of postgresql is pretty 
> remarkable, so hopefully any newer version of postgresql will work for you.
> Sean
> _______________________________________________
> Bioconductor mailing list
> Bioconductor at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/bioconductor
> Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor

Thomas E Adams
National Weather Service
Ohio River Forecast Center
1901 South State Route 134
Wilmington, OH 45177

EMAIL:	thomas.adams at noaa.gov

VOICE:	937-383-0528
FAX:	937-383-0033

More information about the Bioconductor mailing list