[BioC] Warnings after makePDpackage

James MacDonald jmacdon at med.umich.edu
Thu Jul 10 23:28:44 CEST 2008

Hi Ann,

Ann Hess wrote:
> I am trying to use makePDpackage for the Affymetrix Arabidopsis Tiling 
> array.  I ran the following code with no errors:
> library(makePlatformDesign)
> makePDpackage("At35b_MR_v04-2_TIGRv5.bpmap",file1="At35b_MR_v04.cif",manufacturer="affymetrix",type="tiling") 
> The (after exiting R), I ran the following command:
> R CMD check pd.at35b.mr.v04.2.tigrv5
> At this point, I got 4 warnings (excerpted):
> * checking for unstated dependencies in R code ... WARNING
> 'library' or 'require' calls not declared from:
>   oligo
> * checking for missing documentation entries ... WARNING
> Undocumented code objects:
>   pd.at35b.mr.v04.2.tigrv5
> Undocumented data sets:
>   pd.at35b.mr.v04.2.tigrv5
> * checking for code/documentation mismatches ... WARNING
> Error in tools::codoc(package = "pd.at35b.mr.v04.2.tigrv5") :
>   directory 
> '/home/hess/Tiling/CELfiles/pd.at35b.mr.v04.2.tigrv5.Rcheck/pd.at35b.mr.v04.2.tigrv5' 
> does not contain Rd sources
> Execution halted
> * checking Rd \usage sections ... WARNING
> Error in tools::checkDocFiles(package = "pd.at35b.mr.v04.2.tigrv5") :
>   directory 
> '/home/hess/Tiling/CELfiles/pd.at35b.mr.v04.2.tigrv5.Rcheck/pd.at35b.mr.v04.2.tigrv5' 
> does not contain Rd sources
> Execution halted

Yes. The pDPackage won't have any .Rd files, so checking for these 
things and for code/documentation mismatches won't work. Try

R CMD check --no-codoc pd.at35b.mr.v04.2.tigrv5

You might also need to add some other options - see R CMD check --help.

> Just to see what would happen, I also tried:
> R CMD build pd.at35b.mr.v04.2.tigrv5
> and got the following warning:
> * checking for empty or unneeded directories
> WARNING: directory 'pd.at35b.mr.v04.2.tigrv5/man' is empty
> I get an error when I try to load the package in R:
>> library(pd.at35b.mr.v04.2.tigrv5)
> Error in library(pd.at35b.mr.v04.2.tigrv5) :
>   'pd.at35b.mr.v04.2.tigrv5' is not a valid package -- installed < 2.0.0?

This error usually happens when people take package sources and dump 
them in the library folder. If you did something like that, then there's 
your answer. If not then I dunno.

Do note that you need to *install* the package and building does not do 
that. Also note that you don't need to build before installing. The 
canonical way to do things is

R CMD check <thepackage>
R CMD build <thepackage>
R CMD INSTALL <thepackage_version.tar.gz>

but if you just want the thing installed you can skip all that stuff and 
just do

R CMD INSTALL <thepackage>

And one last thing. It's my understanding that makePlatformDesign is on 
its way out, to be replaced by pdInfoBuilder. This is a bit more 
complicated as you will need to first set up a PDInfoPkgSeed object.

The man page is not clear at all about how to do this, but you will need 
  the bpmap and cif file (from the Affy website - it should be in the 
library file) and to do something along these lines:

pkg <- new("AffyTilingPDInfoPkgSeed", bpmapFile=<the bpmapfile>, cifFile 
= <the ciffile>, version = "0.0.1", author = "Ann Hess", email = 
"hess at stat.colostate.edu", genomeBuild = "um, I dunno", biocViews = 

Then install as usual.



> I am working in R version 2.6.0 with makePlatformDesign_1.2.0 on linux 
> redhat.
> I would like to figure out where I have gone wrong before repeating, 
> because it takes several hours to run!
> Any suggestions would be appreciated.
> Ann
> _______________________________________________
> Bioconductor mailing list
> Bioconductor at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/bioconductor
> Search the archives: 
> http://news.gmane.org/gmane.science.biology.informatics.conductor

James W. MacDonald, MS
UMCCC cDNA and Affymetrix Core
University of Michigan
1500 E Medical Center Drive
7410 CCGC
Ann Arbor MI 48109

More information about the Bioconductor mailing list