[BioC] Warnings after makePDpackage

Ann Hess hess at stat.colostate.edu
Thu Jul 10 20:42:50 CEST 2008

I am trying to use makePDpackage for the Affymetrix Arabidopsis Tiling 
array.  I ran the following code with no errors:


The (after exiting R), I ran the following command:
R CMD check pd.at35b.mr.v04.2.tigrv5

At this point, I got 4 warnings (excerpted):

* checking for unstated dependencies in R code ... WARNING
'library' or 'require' calls not declared from:
* checking for missing documentation entries ... WARNING
Undocumented code objects:
Undocumented data sets:
* checking for code/documentation mismatches ... WARNING
Error in tools::codoc(package = "pd.at35b.mr.v04.2.tigrv5") :
does not contain Rd sources
Execution halted
* checking Rd \usage sections ... WARNING
Error in tools::checkDocFiles(package = "pd.at35b.mr.v04.2.tigrv5") :
does not contain Rd sources
Execution halted

Just to see what would happen, I also tried:
R CMD build pd.at35b.mr.v04.2.tigrv5

and got the following warning:
* checking for empty or unneeded directories
WARNING: directory 'pd.at35b.mr.v04.2.tigrv5/man' is empty

I get an error when I try to load the package in R:

> library(pd.at35b.mr.v04.2.tigrv5)
Error in library(pd.at35b.mr.v04.2.tigrv5) :
   'pd.at35b.mr.v04.2.tigrv5' is not a valid package -- installed < 2.0.0?

I am working in R version 2.6.0 with makePlatformDesign_1.2.0 on linux 

I would like to figure out where I have gone wrong before repeating, 
because it takes several hours to run!

Any suggestions would be appreciated.


More information about the Bioconductor mailing list