[BioC] Error in .nextMethod(e1, e2) with updated R and bioC package on MAC OS

Anat Caspi caspian at sas.upenn.edu
Sun Mar 30 14:18:31 CEST 2008


I've read responses to several inquiries regarding the error message which I've
been getting when creating new objects in the BioC package ever since I updated
to the most recent version of R:
Error in .nextMethod(e1, e2)
  comparison of these types is not implemented

I followed the advice which was to update my bioC package:

I also tried:
 update.packages(repos=biocinstallRepos(), ask=FALSE)

I'm still getting the same error.
Here's my traceback after having initiated a read.phenoData() command, but this
seems to occur whenever I call an affy method that requires a new object:
23: eval(expr, envir, enclos)
22: eval(call, callEnv)
21: callNextMethod(e1, e2)
20: classVersion(object)[names(vers)] == vers
19: classVersion(object)[names(vers)] == vers
18: isCurrent(object, class(object))
17: isCurrent(object, class(object))
16: isCurrent(object)
15: isCurrent(object)
14: validator.phenoData(object)
13: validityMethod(object)
12: identical(x, TRUE)
11: anyStrings(validityMethod(object))
10: validObject(.Object)
9: .nextMethod(.Object, ...)
8: eval(expr, envir, enclos)
7: eval(call, callEnv)
6: callNextMethod(.Object, ...)
5: .local(.Object, ...)
4: initialize(value, ...)
3: initialize(value, ...)
2: new("phenoData", pData = pData, varLabels = varLabels)
1: read.phenoData("names.txt", header = TRUE, row.names = 1)

Any help is appreciated.

More information about the Bioconductor mailing list