[BioC] Error in .nextMethod(e1, e2) with updated R and bioC package on MAC OS

Martin Morgan mtmorgan at fhcrc.org
Sun Mar 30 18:38:59 CEST 2008

Hi Anat --

I think you've probably not been successful in updating your packages, 
but it could be that affy or some other package is doing something it is 
not supposed to do.

A possibility is that your attempt to update your Bioconductor packages 
was not successful. A likely cause of this is that Biobase and other 
packages were already loaded (e.g., because you automatically load it 
when you start R) when you tried to update. You must start R WITHOUT 
loading any extra packages (e.g., from the DOS prompt, c:/Program 
Files/R/R-2.6.2/bin/R --vanilla) and then

 >  source("http://bioconductor.org/biocLite.R")
 >  update.packages(repos=biocinstallRepos(), ask=FALSE)

If there are messages saying something along the lines of 'package X 
could not be installed because it is in use', that means the update was 
not successful. Let us know if this is the case.

 From 'traceback', it looks like you're invoking read.phenoData as a 
command from the R prompt. When I do

 > library(Biobase)
 > pd <- read.phenoData()

I get

Warning messages:
1: read.phenoData is deprecated, use read.AnnotatedDataFrame instead
2: The phenoData class is deprecated, use AnnotatedDataFrame (with 

Is this what you get? You will want to pay attention to the warning 
message, and use read.AnnotatedDataFrame instead of read.phenoData. This 
might mean that the format of your input file needs to be changed.

If you see this with some other command, can you tell us exactly what 
that command is?

After loading Biobase, my sessionInfo() is

 > sessionInfo()
R version 2.6.2 Patched (2008-03-24 r44993)


attached base packages:
[1] tools     stats     graphics  grDevices utils     datasets  methods
[8] base

other attached packages:
[1] Biobase_1.16.2

loaded via a namespace (and not attached):
[1] rcompgen_0.1-17

what is yours?


Anat Caspi wrote:
> Hi.b
> I've read responses to several inquiries regarding the error message which I've
> been getting when creating new objects in the BioC package ever since I updated
> to the most recent version of R:
> Error in .nextMethod(e1, e2)
>   comparison of these types is not implemented
> I followed the advice which was to update my bioC package:
>  source('http://bioconductor.org/biocLite.R')
>  biocLite()
> I also tried:
>  source("http://bioconductor.org/biocLite.R")
>  update.packages(repos=biocinstallRepos(), ask=FALSE)
> I'm still getting the same error.
> Here's my traceback after having initiated a read.phenoData() command, but this
> seems to occur whenever I call an affy method that requires a new object:
>  traceback()
> 23: eval(expr, envir, enclos)
> 22: eval(call, callEnv)
> 21: callNextMethod(e1, e2)
> 20: classVersion(object)[names(vers)] == vers
> 19: classVersion(object)[names(vers)] == vers
> 18: isCurrent(object, class(object))
> 17: isCurrent(object, class(object))
> 16: isCurrent(object)
> 15: isCurrent(object)
> 14: validator.phenoData(object)
> 13: validityMethod(object)
> 12: identical(x, TRUE)
> 11: anyStrings(validityMethod(object))
> 10: validObject(.Object)
> 9: .nextMethod(.Object, ...)
> 8: eval(expr, envir, enclos)
> 7: eval(call, callEnv)
> 6: callNextMethod(.Object, ...)
> 5: .local(.Object, ...)
> 4: initialize(value, ...)
> 3: initialize(value, ...)
> 2: new("phenoData", pData = pData, varLabels = varLabels)
> 1: read.phenoData("names.txt", header = TRUE, row.names = 1)
> Any help is appreciated.
> _______________________________________________
> Bioconductor mailing list
> Bioconductor at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/bioconductor
> Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor

More information about the Bioconductor mailing list