[BioC] Downgrading R to an older version

Chong Kim San Allen patcksa at nus.edu.sg
Wed Aug 13 07:43:16 CEST 2014

My server is running Debian and the most stable version of R for Debian is 2.1.5. I decided to use "apititude install r-base=3.1.0" to install a backport version of R but that command just upgraded it to R 3.1.1. I don't know why it installed 3.1.1 instead of 3.1.0?

I have 2 software that I would like to run on my server: ChAMP and MeDIPS. It seems that ChAMP will not run on R 2.1.5 but is fine with R 3.1.1. The reverse is true for MeDIPS. I was told by someone that a compromise is to install R 3.1.0. 

I have tried to force Synaptic Package Manager to install R 3.1.0 by following the instructions on this webpage:


but no matter which mirror I use, I am told by Synaptic Package Manager that it cannot install R3.1.0 because of broken packages.  I have tried to use Synaptic Package Manager to fix the packages but it doesn't work. 

So my question is:

1) Can anyone suggest a way to downgrade to a working R 3.1.0? Maybe through a command line instruction
2) Is there a way to get MeDIPS to work with R3.1.1

Thanks in advance for any help.


More information about the Bioconductor mailing list