[Rd] scan file error (PR#3738)

dmurdoch at pair.com dmurdoch at pair.com
Wed Aug 13 06:39:01 MEST 2003

On Wed, 13 Aug 2003 04:07:27 +0200 (MET DST), you wrote:

>Full_Name: Bart
>Version: 1.7.1
>Submission from: (NULL) (
>When trying to load microarray slides (gpr format) into R 1.7.1, I get the
>following error message
>Error in scan(file = file, what = what, sep = sep, quote = quote, dec = dec,  :
>        line 1057 did not have 43 elements
>I have been able to load the files on another computer before including an XP
>machine. I have also tried to load a different set of gpr files, that also
>worked on an earlier version, but still get the same error message.
>Using an earlier version of R (1.3.1)I did not have these problems.
>Does anyone know of compatibilty issues between R 1.7.1 and Windows XP?

What does line 1057 look like?  What did your command look like that
tried to read the file?  

Please read ?bug.report and give us the necessary information that we
can use to reproduce your problem.  If it really is a bug, we won't be
able to fix it without that.  However, chances are that in simplifying
this to an example you can post, you'll find that it's really not a

Duncan Murdoch

More information about the R-devel mailing list