[Rd] exceeding memory causes crash on Linux

Paul Gilbert pgilbert at bank-banque-canada.ca
Thu Oct 9 12:05:56 MEST 2003

I am having an unusual difficulty with R 1.8.0 on Mandrake 9.1 running a 
problem that takes a large amount of memory. With R 1.7.1  this ran on 
the machine I am using (barely), but now takes more memory than is 
available.  The first two times I tried with R 1.8.0, R exited after the 
program had run for some time, and gave no indication of anything, just 
returned to the shell command prompt. I ran under gdb to see if I could 
get a bettter indication of the problem, and this crashed Linux 
completely, or at least X, but I couldn't get another console either. (I 
haven't had anything crash Linux in a long time.) To confirm this I ran 
R under gdb again, and ran top to verify I was hitting memory 
constraints (which I was), but this time R did give a message "Error: 
cannot allocate a vector of size ..."

I'm not worried about running the problem, but I would like a more 
graceful exit. Might this be related to the change in error handling?

Paul Gilbert

More information about the R-devel mailing list