[Rd] Bugs compiling R-1.7.1 with Intel compilers icc and ifc (PR#4314)

Kurt.Hornik at wu-wien.ac.at Kurt.Hornik at wu-wien.ac.at
Fri Sep 26 21:30:19 MEST 2003

>>>>> Saikat DebRoy writes:

> On Thursday, Sep 25, 2003, at 05:26 US/Eastern, CanisMaior at web.de wrote:
>> Bugs compiling R-1.7.1 with Intel compilers icc and ifc,
>> on x86-computer (Pentium IV) and linux operating system

> Many of those bugs can be fixed by using appropriate configure options. 
> Some of the warnings are serious, but they quite a few of them or fixed 
> yesterday.

> ...

>> 2) delete a wrong path in some Makefiles:
>> -L/usr/local/lib"
>> The quotation mark is the wrong thing. Delete it!

> The problem is in the AC_F77_LIBRARY_LDFLAGS macro. It guesses the
> linker flags by passing a verbose option (-v for ifc) to the compiler.
> For ifc this produces a multiline output, one line continued to the
> next by a \ character. It also contains some " characters. These
> together produces the wrong results. We can fix this by removing all \
> and " from the variable ac_f77_v_output in that macro. I am not sure
> if this breaks anything in other compilers.

Yep, the problem is the "-mGLOB_options_string=......" one gets, and
AC_F77_LIBRARY_LDFLAGS() cannot handle this.  I tend to avoid
overloading stuff from Autoconf (and am not a fan of unconditionally
removing double quotes either), and we have a macro for postprocessing
the AC_F77_LIBRARY_LDFLAGS results anyways.  I've added

    -[a-zA-Z]/*\" | -[a-zA-Z]*\\) # ifc

to this, which worked on the system I tried.  Can people with ifc pls
try again?

Also, it would be nice if someone could donate a few lines on using the
Intel compilers for R-admin.


More information about the R-devel mailing list