[Rd] eigen gives NaN in $vectors (PR#8041)

pkapat_nospam@stat.ohio-state.edu pkapat_nospam at stat.ohio-state.edu
Sun Jul 31 03:53:51 CEST 2005

Full_Name: P Kapat
Version: 2.1.1 (2005-06-20)
OS: GNU/Linux 2.6.8-2-386, Debian testing
Submission from: (NULL) (

Relevant Bugs Ids : 7987, 7989

H is a 100x100 singular but symmetric matrix (a matrix defining the
neighbourhood structure for a spatial data) available from..

> load(file="bugMatrix.RData")
> ls()
> I <- diag(rep(1,100))
> g <- 0.1318467
> M <- I - g*H 
> y <- eigen(M)
> y$vec[,91]
## all NaNs

Interestingly, as suggested in bug id 7989, this is very sensitive to the
scaling factor g. The error dissapears with even a slightly different value of
g, like 0.131846 instead of 0.1318467.

I run a Debian/testing (2.6.8-11 kernel) on Dell P4 i386 arch. This error does
not occur on Windows XP (R 2.1.1) or Red Hat Enterprise GNU/Linux 2.6.9-11
running R 2.1.1. I have tried on both of them. Seems like a wiered bug !!

Dept. of Stat. OSU.

More information about the R-devel mailing list