[Rd] Installation of RGtk2 (PR#10519)

Oleg Sklyar osklyar at ebi.ac.uk
Mon Dec 17 16:23:44 CET 2007

RGtk2 is a packages that is a wrapper for GTK+ GUI toolkit. GTK+ itself
is a large separate software package. I do not know if GTK+ is delivered
within the RGtk2, but I doubt it as the former is quite big (at least
with my own package that uses GTK, users need to install GTK
separately). Now on Windows you can install GTK runtime environment as
any other application by downloading it from here:
http://gladewin32.sf.net and running a Windows-standard installation.
The default installation should be fine. After you have GTK installed,
reinstall the RGtk2 package if it does not work automatically. 

Actually I just checked http://www.ggobi.org/rgtk2/ and it says that
indeed you need to install GTK separately.


On Mon, 2007-12-17 at 15:00 +0100, caroline.keef at jbaconsulting.co.uk
> Full_Name: Caroline Keef
> Version: 2.6.1
> OS: Windows XP
> Submission from: (NULL) (
> I have tried to install the package rggobi which if I'm right requires the
> package RGtk2 
> If I install RGtk2 using the install.packages (I used the UK (Bristol) mirror, I
> haven't tried any other mirror) within R and then use library(RGtk2) I get the
> following message box
> "This application has failed to start because libtak-1.0-0.dll was not found. 
> Re-installing the application may fix this problem."
> I click ok and the following is printed to the R console.
> Error in dyn.load(file, ...) : 
>   unable to load shared library
> 'C:/PROGRA~1/R/R-26~1.1/library/RGtk2/libs/RGtk2.dll':
>   LoadLibrary failure:  The specified module could not be found.
> Error in .C("R_gtkInit", length(args), x = args, PACKAGE = "RGtk2") : 
>   C symbol name "R_gtkInit" not in DLL for package "RGtk2"
> In addition: Warning message:
> In fun(...) :
>   Failed to load RGtk2 dynamic library:Error in dyn.load(file, ...) : 
>   unable to load shared library
> 'C:/PROGRA~1/R/R-26~1.1/library/RGtk2/libs/RGtk2.dll':
>   LoadLibrary failure:  The specified module could not be found.
> Error : .onLoad failed in 'loadNamespace' for 'RGtk2'
> Error: package/namespace load failed for 'RGtk2'
> I've re-started R again and the same happened.  I've also tried downloading the
> RGtk2 zip files from the CRAN website and installing from a local zip file
> option which gave the same results.  I haven't tried re-installing R to get
> around this problem.
> ______________________________________________
> R-devel at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel
Dr Oleg Sklyar * EBI-EMBL, Cambridge CB10 1SD, UK * +44-1223-494466

More information about the R-devel mailing list