[Rd] R-devel Digest, Vol 126, Issue 18

Arrain Txikiak arraintxikiak at gmail.com
Tue Aug 20 22:05:11 CEST 2013

Thank you, it does work now indeed.  My platform is 32 bit.

-- Txikiak

On 08/20/2013 12:00 PM, r-devel-request at r-project.org wrote:
> Date: Mon, 19 Aug 2013 14:08:33 +0100
> From: Prof Brian Ripley <ripley at stats.ox.ac.uk>
> To: r-devel at r-project.org
> Subject: Re: [Rd] Issues in installing R-devel
> Message-ID: <521218D1.1050502 at stats.ox.ac.uk>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> Please try again: this has already been reported and fixed.
> BTW, you did not follow the posting guide and report your platform.
> This issue was only for 32-bit builds.
> On 19/08/2013 11:34, Arrain Txikiak wrote:
>> Dear list,
>> I have tried to compile and install the development version of R, but
>> met some problems I'm not quite sure how to resolve.
>> I have downloaded the code from your repository, configured, and tried
>> to compile using the makefile, as follows:
>> [atxi at aquario R]$ svn co http://svn.r-project.org/R/trunk
>> [atxi at aquario R]$ cd trunk
>> [atxi at aquario R]$ ./tools/rsync-recommended
>> [atxi at aquario R]$ ./configure --enable-R-shlib
>> [atxi at aquario R]$ make
>> I'm getting the following error:
>> gcc -std=gnu99 -Wl,--export-dynamic -fopenmp  -L/usr/local/lib -o R.bin
>> Rmain.o  -L../../lib -lR -lRblas
>> ../../lib/libR.so: undefined reference to `SHORT_VEC_LENGTH'
>> collect2: ld returned 1 exit status
>> This does not seem to be a missing dependency, as the complaint is about
>> something included in the R code.  I had previously successfully
>> installed R-devel using the exact same commands on the same machine.
>> What am I doing wrong?
>> In advance thank you for support.
>> -- Txikiak

More information about the R-devel mailing list