[Rd] missing binaries in R-devel windows snapshot 78175

Bravington, Mark (Data61, Hobart) M@rk@Br@v|ngton @end|ng |rom d@t@61@c@|ro@@u
Fri Apr 10 02:41:44 CEST 2020

> On Thu, Apr 9, 2020 at 12:44 PM Bravington, Mark (Data61, Hobart)
> <Mark.Bravington using data61.csiro.au> wrote:
> >
> > The "r-devel snapshot build" 78175 on Windows--- a dot-exe installer--- seems to be missing a couple of files in its bin/i386 folder: Rterm.exe and Rgui.exe. Both are present in its bin/x64 folder (and in the i386 folder for current R).

From: Jeroen Ooms <jeroen using berkeley.edu>
Sent: Thursday, 9 April 2020 21:32
To: Bravington, Mark (Data61, Hobart)
Cc: R-Devel-2
Subject: Re: [Rd] missing binaries in R-devel windows snapshot 78175

> I just tested this and as far as I can tell there are no missing
> files. Are you sure there isn't a local problem with your system
> permissions or antivirus that is removing the files?

You're quite right--- my apologies. I've been Cylanced (without it having the politeness to actually tell me, grrrr). I tried again with the 78172 build that you used, and the two dot-exe files are there immediately after installation--- but 10 minutes later they're gone. One question below about the md5 stuff, though:

> Try to verify the md5 of the installer; some enterprise firewalls are
> tampering with downloads:

>   openssl::md5(url('https://cran.r-project.org/bin/windows/base/R-devel-win.exe'))
>   readLines('https://cran.r-project.org/bin/windows/base/md5sum.txt.R-devel')

Thanks for the tip. I did that, and both give the same output. But:

 - If I run 'md5sum' on my local copy of the 78182 installer (ie the file I've just downloaded) I again get the same signature as per your two lines. (It's not the firewall, it's Cylance.)
 - Yet if I run 'openssl::md5( <local copy of installer>)' I get a different signature!
That seems strange..?

Thanks for your help

More information about the R-devel mailing list