[Rd] configure --with-pcre1 fails with latest R 4.0 on Ubuntu 14.04

Hervé Pagès hp@ge@ @end|ng |rom |redhutch@org
Tue Mar 17 20:18:31 CET 2020

Using --with-pcre1 to configure the latest R 4.0 (revision 77988) on an 
Ubuntu 14.04.5 LTS system gives me the following error:

checking if lzma version >= 5.0.3... yes
checking for pcre2-config... no
checking for pcre_fullinfo in -lpcre... yes
checking pcre.h usability... yes
checking pcre.h presence... yes
checking for pcre.h... yes
checking pcre/pcre.h usability... no
checking pcre/pcre.h presence... no
checking for pcre/pcre.h... no
checking if PCRE1 version >= 8.32 and has UTF-8 support... no
checking whether PCRE support suffices... configure: error: pcre2 
library and headers are required, or use --with-pcre1

Maybe the real problem is that the PCRE version on this OS is 8.31?

The error message is not particularly helpful.


Hervé Pagès

Program in Computational Biology
Division of Public Health Sciences
Fred Hutchinson Cancer Research Center
1100 Fairview Ave. N, M1-B514
P.O. Box 19024
Seattle, WA 98109-1024

E-mail: hpages using fredhutch.org
Phone:  (206) 667-5791
Fax:    (206) 667-1319

More information about the R-devel mailing list