[Rd] configure --with-pcre1 fails with latest R 4.0 on Ubuntu 14.04

Tomas Kalibera tom@@@k@||ber@ @end|ng |rom gm@||@com
Wed Mar 18 09:08:52 CET 2020

On 3/17/20 8:18 PM, Hervé Pagès wrote:
> Using --with-pcre1 to configure the latest R 4.0 (revision 77988) on 
> an Ubuntu 14.04.5 LTS system gives me the following error:
> ...
> checking if lzma version >= 5.0.3... yes
> checking for pcre2-config... no
> checking for pcre_fullinfo in -lpcre... yes
> checking pcre.h usability... yes
> checking pcre.h presence... yes
> checking for pcre.h... yes
> checking pcre/pcre.h usability... no
> checking pcre/pcre.h presence... no
> checking for pcre/pcre.h... no
> checking if PCRE1 version >= 8.32 and has UTF-8 support... no
> checking whether PCRE support suffices... configure: error: pcre2 
> library and headers are required, or use --with-pcre1
> Maybe the real problem is that the PCRE version on this OS is 8.31?

Yes, R requires PCRE version at least 8.32 as documented in R-Admin, and 
this is since September 2019.

> The error message is not particularly helpful.

An earlier version of the message gave the requirement explicitly, when 
people would have been more likely to have that old versions of PCRE1.
The few who still have it now need to see also the output line above to 
get the requirement and/or look into the manual.

R 4.0 is still keeping support for PCRE1 (>=8.32), but PCRE2 should be 
used whenever possible.


> Thanks,
> H.

More information about the R-devel mailing list