[R] Installation problems under windows NT

Prof Brian D Ripley ripley at stats.ox.ac.uk
Fri Jun 29 10:14:43 CEST 2001

On Fri, 29 Jun 2001, Joerg Wegner wrote:

> Hello,
> i' ve installed the binary distribution 1.2.3 without any problem, BUT
> then i've tried to install the multiv package.

That's not the current version.

> 1. pure cygwin or the rtools, perl and mingw doesn't work. (The download
> paths for perl and WinHelp in the file readme.packages are'nt correct).
>     WinHELP is not available, can you recommend a dowload adress ?

Well, you are using an obselete version. readme.packages says:

There is a `portal' with current links at

However, I've just checked the addresses and they are
correct in the current version.

Why didn't you check the portal: it is provided precisely for people
who have difficulty?

> 2. Although there is  the same problem with .chm-files in the FAQ
> reported, i've the same problem.

What does that mean?

> In .../src/gnuwin32/Makefile are the lines
> WINHELP = NO # Use one of NO, CHM, BOTH (chm and winhelp)
> However the Makefile reports the error that there is no multiv.chm file
> available, o.k. so i tried
> rcmd INSTALL -docs=no multiv
> it doesn't work. Then i  documented the following lines in the Makefile
> #ifeq ($(strip $(HELP)),YES)
> $($*-HELP)help-$*
> contents-$*
> #ifeq ($(strip $(WINHELP)),CHM)
> # $(MAKE) -C ./help RHOME=$(RHOME) PKGDIR=$(PKGD) RLIB=$(RLIB) chm-$*
> #endif
> #ifeq ($(strip $(WINHELP)),BOTH)
> # $(MAKE) -C ./help RHOME=$(RHOME) PKGDIR=$(PKGD) RLIB=$(RLIB) winhlp-$*
> # also makes chm
> #endif
> #endif
> That work's ...

Something's wrong with your make.

> 3. Now theoretically the directory multiv was correctly created in the
> .../library path ... but the function pca() can be still not found.
> The function help(pca) after link.html.help() reports that the requested
> function doesn't exist.
> The R_HOME and the R_LIBS(R_LIB, RLIB) environment varible are correctly
> initialized !

You did do library(multiv), didn't you?

> 4. I've tried the package.install() command, but the function doesn't
> exist.

Right, it's called install.packages().  Where did you find package.install
mentioned?  It's nowhere in the source tree.

>     I've tried the binary package distribution, but it told me that
> there are no man pages available.
>     I've tried to use the source package distribution, but there i have
> the problems with the multiv.chm file. (WinHELP not available !)
>     Then i skipped the tutorial installation, BUT the packages arent't
> installed correctly, although rcmd check multiv reports no errors ???
> So ... where did i make the mistake ???

Many places, I suspect.

- use install.packages, not packages.install.
- there is a binary version of multiv on CRAN, and it is working.
- I think you omitted to use library(multiv).
- You seem to have trouble resolving correct addresses

Brian D. Ripley,                  ripley at stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272860 (secr)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list