[R] RE: mvtnorm package installation failure

jonathan_li@agilent.com jonathan_li at agilent.com
Tue Jul 9 21:09:04 CEST 2002

Hi Dirk,

It was actually Debian "testing" that has R 1.4.0. Debian "stable" has R 0.9 or something really old
like that. 

Anyways, I did what A.J. Rossini suggested:
# apt-get install libreadline4-dev
Then I installed R-1.5.1 from Debian "unstable". The installation of "mvtnorm" has no trouble after this.

I think that you are probably right: the "unstable" version of R 1.5.1 on Debian is built without readline
support for some reasons. Or it has something to do with broken Debian dependency? 

Best Regards,

-----Original Message-----
From: Dirk Eddelbuettel [mailto:edd at debian.org]
Sent: Tuesday, July 09, 2002 10:58 AM
To: jonathan_li at agilent.com; Torsten.Hothorn at rzmail.uni-erlangen.de;
r-help at stat.math.ethz.ch
Subject: Re: [R] RE: mvtnorm package installation failure


> I tried to re-intall R from Debian "stable", in which R's version is 1.4.0. And the installation 
> of "mvtnorm" works. 

Debian's own "stable" R is way older; this must have been a user-contributed one. And I suspect
that it was build without readline support (see below).

> I then re-installed R yet again from Debian "unstable" (woody), in which R's version is 1.5.1.
> The installation of "mvtnorm" fails again with the same error message. Another package that 
> failed with the same error message is "mclust". 
> >From these phenomena, I suspect that the problem is with the Debian version of R 1.5.1. Can someone
> point out a fix?  


> > Hi, I want to thank you in advance for any assistance you may give: I
> > had
> > trouble installing the mvtnorm package. Here is the error message I
> > encountered:
> > 
> > R CMD INSTALL mvtnorm
> > * Installing *source* package 'mvtnorm' ...
> > ** libs
> > gcc -shared  -o mvtnorm.so mvt.o   -L/usr/lib/gcc-lib/i386-linux/2.95.4
> > -lreadline -ldl -lncurses -lg2c-pic -lm -L/usr/lib/R/bin -lR
> > /usr/bin/ld: cannot find -lreadline

This is a pretty clear message:  you need to install the matching -dev package 
for readline so that you can /compile and link/ against readline, currently you can 
only run pre-built programs using readline.  

> > collect2: ld returned 1 exit status
> > make: *** [mvtnorm.so] Error 1
> > ERROR: compilation failed for package 'mvtnorm'


According to the latest figures, 43% of all signatures are totally worthless.   
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list