[R] help.search problem

Martin Maechler maechler at stat.math.ethz.ch
Tue Sep 6 18:11:27 CEST 2005

>>>>> "ToUz" == Uzuner, Tolga <tolga.uzuner at csfb.com>
>>>>>     on Tue, 6 Sep 2005 16:35:53 +0100 writes:

    ToUz> Hi there,
    ToUz> I am using 2.0.1 . However, I was not having this problem with this version of R when I first installed it and started using it.

yes.  It only happens because of an ``incorrectly installed package'' 
installed somewhere in

and you may have ``wrong-installed'' it only recently.

If you would upgrade to R 2.1.1, the problem would go away,
insofar as  help.start() would report about the package(s) with
invalid installation.
Otherwise (in R 2.0.1), it's somewhat tedious to find IIRC:
You may set
    options(error = recover)
immediately before 

and then inspect the pretty large matrix with the invalid entry
leading to the error.
The matrix has one row per package, and so you can find the
invalid package.

Once you know that, remove the package, and try again.

[As hinted at, you should rather upgrade R]

Martin Maechler

    ToUz> Thanks for your suggestion, I tried it, but that doesn't work either:

    >> help.search("tps")
    ToUz> Error in rbind(...) : number of columns of matrices must match (see arg 8)
    >> utils::help.search("tps")
    ToUz> Error in rbind(...) : number of columns of matrices must match (see arg 8)

    ToUz> Traceback results below:

    ToUz> "Convert Sweave Syntax", "Sweave Driver Utilities", "Find Objects by (Partial) Name", 


    ToUz> "winDialog", "winMenuAdd", "flush.console"))
    ToUz> 2: do.call("rbind", dbMat[, 1])
    ToUz> 1: utils::help.search("tps")

    ToUz> -----Original Message-----
    ToUz> From: Henrik Bengtsson [mailto:hb at maths.lth.se]
    ToUz> Sent: 06 September 2005 15:29
    ToUz> To: Uzuner, Tolga
    ToUz> Cc: 'r-help at stat.math.ethz.ch'
    ToUz> Subject: Re: [R] help.search problem

    ToUz> What version of R and what operating system?  What packages do you have 
    ToUz> loaded?

    ToUz> Try utils::help.search("tps"), does that work? Have you tried it in a 
    ToUz> fresh R session, i.e. start with R --vanilla.

    ToUz> If you can't get it to work after this, report the above information 
    ToUz> plus what you get from traceback() after you get the error.

    ToUz> Cheers

    ToUz> Henrik

    ToUz> Uzuner, Tolga wrote:
    >> Dear Fellow R Users,
    >> I have recently come across a weird problem with help.search:
    >>> help.search("tps")
    >> Error in rbind(...) : number of columns of matrices must match (see arg 8)
    >> This happens no matter what I search for...
    >> Any thoughts ?
    >> Thanks,
    >> Tolga

More information about the R-help mailing list