[R] in unix opening data object created under win

toby909 at gmail.com toby909 at gmail.com
Fri May 25 02:33:02 CEST 2007

On Unix R's version is 2.3.1 and on PC its 2.4.1.

I dont have the rights to install newer version of R on Unix.

I tried different upload methods. No one worked.

On Unix it looks as follows (dots to hide my userid):

 > load("/afs/ir/users/........../project/ps/data/dtaa")
 > head(dtaa)
      hospid     mfpi1 mfpi2 mfpi3     mfpi4 mfpi5 mfpi6     mfpi7 mfpi8
NA        9 0.1428571     1   0.5 0.2857143  0.50   0.0 0.3333333     0
4041      9 0.1428571     0   0.0 0.2857143  0.25   0.2 0.0000000     0
NA   0.3333333
4041 1.0000000

The data comes through but its screwed up.

Thanks for your help.


Liaw, Andy wrote:
> What are the versions of R on the two platform?  Is the version on Unix
> at least as new as the one on Windows?
> Andy 
> From: toby909 at gmail.com
>>Hi All
>>I am saving a dataframe in my MS-Win R with save().
>>Then I copy it onto my personal AFS space.
>>Then I start R and run it with emacs and load() the data.
>>It loads only 2 lines: head() shows only two lines nrow() als 
>>say it has only 2 
>>lines, I get error message, when trying to use this data 
>>object, saying that 
>>some row numbers are missing.
>>If anyone had similar situation, I appreciate letting me know.
>>Best Toby
>>R-help at stat.math.ethz.ch mailing list
>>PLEASE do read the posting guide 
>>and provide commented, minimal, self-contained, reproducible code.
> ------------------------------------------------------------------------------
> Notice:  This e-mail message, together with any attachments,...{{dropped}}
> ______________________________________________
> R-help at stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list