[R] Problems installing RODBC as part of Rcmdr and as separate package

Marc Schwartz marc_schwartz at comcast.net
Fri Feb 20 16:39:26 CET 2009

on 02/20/2009 09:27 AM John Sorkin wrote:
> Fedora 10
> R 2.8.1
> I hope someone can tell me the meaning of error I received trying to install RODBC and how I can get around the problem. 
> n.b. The error originally occurred then I was installing Rcmdr. I then tried to install RODBC separately and received the same error.
> checking sql.h usability... no
> checking sql.h presence... no
> checking for sql.h... no
> checking sqlext.h usability... no
> checking sqlext.h presence... no
> checking for sqlext.h... no
> configure: error: "ODBC headers sql.h and sqlext.h not found"
> ERROR: configuration failed for package 'RODBC'
> ** Removing '/usr/lib/R/library/RODBC'
> The downloaded packages are in
> 	/tmp/RtmpA1nKF2/downloaded_packages
> Updating HTML index of packages in '.Library'
> Warning message:
> In install.packages("RODBC") :
>   installation of package 'RODBC' had non-zero exit status


As root:

  yum install unixODBC unixODBC-devel

You need the unixODBC and the devel RPMs, the latter of which provides
the requisite header files.


Marc Schwartz

More information about the R-help mailing list