[R] install "multtest" and "preprocessCore" packages in Bioconductor library

UyenThao Nguyen unguyen at tethysbio.com
Wed Nov 30 18:57:36 CET 2011

Hi All,

I've tried to install these "multtest" and "preprocessCore" packages in Mac, but kept getting error messages. I tried to load the packages using 2 ways:

1. Installed from BioConductor (sources)
2. And installed from BioConductor (binaries)

Both ways, I got these error messages:

For preprocessCore:
ld: warning: directory '/usr/local/lib' following -L not found
ld: library not found for -lgfortran
collect2: ld returned 1 exit status
make: *** [preprocessCore.so] Error 1
ERROR: compilation failed for package ‘preprocessCore’
* removing ‘/Library/Frameworks/R.framework/Versions/2.10/Resources/library/preprocessCore’
* restoring previous ‘/Library/Frameworks/R.framework/Versions/2.10/Resources/library/preprocessCore’

For multtest:
ld: warning: directory '/usr/local/lib' following -L not found
** arch - x86_64

Looks like the error got to do with L drive, which I don't know how to fix it. Please help. Any suggestions will be greatly appreciated.

Thank you very much,

More information about the R-help mailing list