[R] Problem with inconsolata font (again) --- on Fedora 17 this time.

Milan Bouchet-Valat nalimilan at club.fr
Fri Jan 11 11:10:03 CET 2013

Le vendredi 11 janvier 2013 à 14:50 +1300, Rolf Turner a écrit :
> Some while ago I posted a problem on this list concerning a failure of
> R CMD check on one of my packages that resulted from LaTeX being
> unable to find the "inconsolata" font.  This was under the Ubuntu OS.
> This was solved, thanks to advice I got from this list, basically by
> doing
>      sudo apt-get install texlive-fonts-extra
> I am now (for reasons which I won't go into) running Fedora 17, on a
> different computer.  Now LaTeX cannot find the necessary inconsolata.sty
> file.
> I googled around a bit, and an item I found led me to check whether I
> actually had texlive installed on my (new) system.  I hadn't!!!  So I did
>      sudo yum install texlive
> and that seemed to work.  But then the item I'd found indicated that I
> should do
>      sudo yum install texlive-inconsolata, texlive-inconsolata-font
> But I got:
> > No package texlive-inconsolata, available.
> > No package texlive-inconsolata-font available.
> I also tried
>      sudo yum install texlive-fonts-extra
> with a similar result.
> Can anyone give me a simple recipe as to how to get the inconsolata font
> and the associated inconsolata.sty?
texlive-inconsolata is present on Fedora 18 at least. You can try
installing it manually and check if it works for F17:

But what does this command return?
yum search inconsolata

My two cents

More information about the R-help mailing list