[R] ggplot2 will not install after system upgrade

Jeff Trefftzs jeff at trefftzs.org
Thu Sep 3 23:53:08 CEST 2015

On Thu, 2015-09-03 at 16:47 -0400, Ista Zahn wrote:
> Hi Jeff,
> Your chances of getting a useful response will increase if you
> provide
> some additional information. For example, which version of R? Which
> version of ggplot2? 

Sorry.  R was version 3.2.1
ggplot2 1.0.1

> What sequence of commands produces the error?

install.packages("ggplot2") (or various equivalents while in R-Studio

> What
> _exactly_ does the error message say?

I was working on my laptop, where I didn't have email enabled, so I was
unable to cut & paste all the output.  The last bit of the error
messages boiled down to "unable to find libicui18n.so.50.  No such file
or directory"

> update.packages(ask=FALSE, checkBuilt=TRUE)
> install.packages("ggplot2")

I hadn't tried that.  

Follow-up:  On the laptop I downgraded to R-3.1.3 and things worked
again.  The various error messages I got were confusing.  When I tried
to install ggplot2 from the first US mirror the https server at
Berkeley), it told me "gplot2 not available for R 3.2.1".  When I tried
one of the other servers (e.g., other Berkeley server, or the UCLA
server) it would download, and come to grief with the libicu message.

But downgrading to R 3.1.3 seems to have cured things.

I'm still baffled, however, since I'm writing this on my desktop
computer which has R version 3.2.1 and a successful install of ggplot2
-1.0.1 actually working.

Jeff Trefftzs

More information about the R-help mailing list