[R] Possible solution to R installation problemst for Linux Mint 19 users

Jeff Newmiller jdnewm|| @end|ng |rom dcn@d@v|@@c@@u@
Sun Jul 22 07:34:30 CEST 2018

Each Mint version builds from an Ubuntu version. I don't use Mint. but this [1] web page tells me you should be pulling from a Bionic repo. Artful may work for you now, but in general it is risky to mix distribution revisions.

Note that this informative discussion should have occurred on the R-sig-debian mailing list, as it involves the intersection of R and debian derivatives, and is not about the R language as this mailing list is.

[1] https://linuxmint.com/download_all.php

On July 21, 2018 5:50:02 PM PDT, Clive Nicholas via R-help <r-help using r-project.org> wrote:
>If you're a newly-minted (pun _fully_ intended) user of Linux Mint 19
>("Tara") and you find you're having issues installing R (as I just
>please read on as I may have a solution for you.
>To set out the context, the problem looks like this:
>You (naturally) consult the relevant webpage at cran.r-project.org for
>Linux Mint system (ubuntu) and add the pub key (I've always used
>Rutter's). On my last Linux Mint system (18.2), I was using the
>deb http://cran.ma.imperial.ac.uk/bin/linux/ubuntu xenial/
>deb-src http://cran.ma.imperial.ac.uk/bin/linux/ubuntu xenial/
>which worked fine for me. Unfortunately on my new Linux Mint 19 system:
>clive using climate:~$ sudo apt-get update
>clive using climate:~$ sudo apt-get upgrade
>clive using climate:~$ sudo apt-get install r-base r-base-core r-base-dev
>Reading package lists... Done
>Building dependency tree
>Reading state information... Done
>Some packages could not be installed. This may mean that you have
>requested an impossible situation or if you are using the unstable
>distribution that some required packages have not yet been created
>or been moved out of Incoming.
>The following information may help to resolve the situation:
>The following packages have unmet dependencies.
> r-base-core : Depends: libcurl3 (>= 7.28.0) but it is not going to be
>            Depends: libpng12-0 (>= 1.2.13-4) but it is not installable
>               Depends: libreadline6 (>= 6.0) but it is not installable
>E: Unable to correct problems, you have held broken packages.
>No matter how many legitimate bash calls I made, such as
>sudo apt-get -f install
>sudo apt-get --fix-broken install r-base r-base-core r-base-dev
>nothing worked: I would simply get variations of the same error.
>It turns out the solution is to switch away from -xenial- to *-artful-*
>repository I've never used before and which appears to be the newest of
>the Ubuntu repositories), so that
>deb http://cran.ma.imperial.ac.uk/bin/linux/ubuntu artful/
>deb-src http://cran.ma.imperial.ac.uk/bin/linux/ubuntu artful/
>(or whichever is your favourite mirror).
>clive using climate:~$ sudo apt-get install r-base r-base-core r-base-dev
>Reading package lists... Done
>Building dependency tree
>Reading state information... Done
>The following additional packages will be installed:
>cdbs dh-translations jq libfile-which-perl libjq1 libonig4
>r-cran-boot r-cran-class r-cran-cluster r-cran-codetools r-cran-foreign
>  r-cran-lattice r-cran-mass r-cran-matrix r-cran-mgcv r-cran-nlme
>r-cran-nnet r-cran-rpart r-cran-spatial r-cran-survival r-recommended
>Suggested packages:
>  devscripts ess r-doc-info | r-doc-pdf r-mathlib r-base-html
>Recommended packages:
>  r-base-html r-doc-html
>The following NEW packages will be installed
>cdbs dh-translations jq libfile-which-perl libjq1 libonig4
>r-base r-base-core r-base-dev r-cran-boot r-cran-class r-cran-cluster
>r-cran-foreign r-cran-kernsmooth r-cran-lattice r-cran-mass
>r-cran-mgcv r-cran-nlme r-cran-nnet r-cran-rpart r-cran-spatial
>  r-recommended scour
>0 to upgrade, 27 to newly install, 0 to remove and 3 not to upgrade.
>Need to get 39.5 MB of archives.
>After this operation, 59.9 MB of additional disk space will be used.
>Do you want to continue? [Y/n] y
>Get:1 http://ftp.snt.utwente.nl/pub/os/linux/ubuntu bionic/universe
>libonig4 amd64 6.7.0-1 [119 kB]
>Setting up r-base (3.4.4-1ubuntu1) ...
>clive using climate:~$ R
>R version 3.4.4 (2018-03-15) -- "Someone to Lean On"
>Copyright (C) 2018 The R Foundation for Statistical Computing
>Platform: x86_64-pc-linux-gnu (64-bit)
>R is free software and comes with ABSOLUTELY NO WARRANTY.
>You are welcome to redistribute it under certain conditions.
>Type 'license()' or 'licence()' for distribution details.
>  Natural language support but running in an English locale
>R is a collaborative project with many contributors.
>Type 'contributors()' for more information and
>'citation()' on how to cite R or R packages in publications.
>Type 'demo()' for some demos, 'help()' for on-line help, or
>'help.start()' for an HTML browser interface to help.
>Type 'q()' to quit R.
>> q()
>Save workspace image? [y/n/c]: n
>clive using climate:~$
>*Volia!* (Okay, so it doesn't install R 3.5.1 - the latest version -
>that should eventually correct itself with future updates.)
>So, if you're having the same R installation problems I've just had
>migrating to Linux Mint 19, this should work for you. Good luck. :)

Sent from my phone. Please excuse my brevity.

More information about the R-help mailing list