[Rd] Re: [R] installing on alpha (tru64)

Martin Maechler maechler at stat.math.ethz.ch
Mon Sep 27 08:39:44 CEST 2004

>>>>> "Alexa" == Alexa Sorant <ajms at mail.nih.gov>
>>>>>     on Tue, 21 Sep 2004 18:01:00 -0400 writes:

    Alexa> Dear Martin Maechler, I have tried installing today's
    Alexa> version of R-2.0.0 and have exactly the same problem.

I'm reverting to R-devel.  Please *never* direct such topics to
individuals unless they invite you particularly to it.

    Alexa> I have read INSTALL and the relevant sections of "R
    Alexa> Installation and Administration" (which does
    Alexa> recommend the GNU make).  We have the default Tru64
    Alexa> unix "make" and a POSIX "make" which I also tried.

    Alexa> I do not have the GNU version of "make" and have not
    Alexa> found it easy in the past when I looked into
    Alexa> obtaining GNU software for our platform.  It would be
    Alexa> unfortunate if that is the only solution.

I don't know for sure, but I doubt that it would be difficult to
get a working GNU make on Tru64 .. though that may not be the
important thing at the moment.

    Alexa> What is frustrating is that I had no trouble
    Alexa> installing an earlier version of R (1.4.0), 

that was 3 year ago -- a "decade" in software time-space
if we hadn't changed things, R would not collaborate with
today's (as opposed to 2001's) operating systems, system
libraries, compiler, etc.

    Alexa> so it seems that the installation procedure has been
    Alexa> changed along with the software.

I'm sure the software on your computer has been changed in other
ways as well during the last 3 year; that's simply inevitable

    Alexa> The "include" works fine when I specify an absolute
    Alexa> path or when I put a definition of top_srcdir prior
    Alexa> to it (but that seems to cause other problems).  I am
    Alexa> thinking that I may have to put in an absolute path
    Alexa> in other places as well to get this to work.  But
    Alexa> that may take a considerable time to trace through
    Alexa> all of the various make files.

that definitely shouldn't be necessary.
We'd rather have to see what went wrong and may only need a
small change to fix it.

We may need more details (e.g., output of 'configure' ; exact error message).

Have you followed my advice below and installed into a different 
*build* directory ?
Please reply to R-devel.

Martin Maechler

    Alexa> Alexa Sorant

    Alexa> At 04:06 AM 9/21/2004, you wrote:
    >> >>>>> "Alexa" == Alexa Sorant <ajms at mail.nih.gov> >>>>>
    >> on Mon, 20 Sep 2004 17:35:43 -0400 writes:

    Alexa> I am trying to install R-1.9.1 on an alpha (Tru64
    Alexa> unix) platform.  I had no problem previously
    Alexa> installing R-1.4.0, but cannot get the new
    Alexa> installation to work.  First I ran "configure"
    Alexa> specifying an alternate installation

    Alexa> directory: ./configure --prefix=/appl/R-1.9.1
    >>  We even recommend using an alternate *build* directory:
    >> mkdir <Rbuild> cd <Rbuild> ../<Rsrc>/configure ....
    >> and indeed, since R 2.0.0 is beta now (which means
    >> "testing" and almost stable, not "unstable"!), we'd
    >> appreciate (and feel more willing to support you) if
    >> you'd tried to install R-2.0.0 directly.
    Alexa> then ran "make" (note that this is NOT gmake, which
    Alexa> may make the difference).  The error message I get
    Alexa> is: Make: cannot open /share/make/vars.mk.  Stop.
    Alexa> The file share/make/vars.mk is there and readable,
    Alexa> but share is a subdirectory of the main installation
    Alexa> directory.  Upon examining Makefile and associated
    Alexa> files, I found a statement in Makeconf include
    Alexa> $(top_srcdir)/share/make/vars.mk which I suspected
    Alexa> was the problem -- perhaps the definition of
    Alexa> top_srcdir not is carrying over from the Makefile
    Alexa> that references Makeconf.
    >>  yes, that seems clear.  If your 'make' is not supporting
    >> such 'include' statements in Makefiles, you definitely
    >> must use GNU make (seemingly called 'gmake' on alpha) !
    >> Did you look at the INSTALL file, or even consult the "R
    >> Administration and Installation" manual (available from
    >> R-projec.org as well) ?
    Alexa> (One reason I suspect this statement is that it is
    Alexa> new since the version of R that I installed easily,
    Alexa> as well as the early reference to this particular
    Alexa> file.)
    Alexa> I have tried a bunch of ways of modifying this
    Alexa> statement, including an explicit path in this
    Alexa> statement.  I think that did work, but a similar
    Alexa> problem then occurred at a later point that I haven't
    Alexa> yet located.
    Alexa> Has anyone gotten this installation to work on this
    Alexa> platform?
    Alexa> Alexa J. M. Sorant NIH/NHGRI 333 Cassell Drive Suite
    Alexa> 2000 Baltimore, MD 21224
    Alexa> ajms at mail.nih.gov

More information about the R-devel mailing list