[Rd] Using SVN + SSH on windows

Henrik Bengtsson hb at stat.berkeley.edu
Sat Mar 27 18:00:25 CET 2010

2010/3/27 hb <hb at stat.berkeley.edu>:
> On Sat, Mar 27, 2010 at 3:12 PM, Christophe Genolini <cgenolin at u-paris10.fr> wrote:
>> Hi the list,
>> I try to use R-Forge for developping a projet. I am using tortoise SVN (last
>> version) but I do not manage to Commit. I read the R-Forge user Manual and
>> some post on  but I do not manage to find the solution. Here is what I did:
>> 1/ I download 'puttygen.exe'. I generate a key (256 bits).
>> 2/ I save the private key in a file 'private.ppk' on my computer.
>> 3/ I copy-paste the public key on sourceforge
>> ssh-rsa
>> AAAAB3NzaC1yc2EAAAABJQAAACEAobwycGGZrMZ39i7Vtrdk3ahN1hVw/tPoiShJGk1xjRs=
>> rsa-key-20100327
>> 4/ I wait two hours.
>> 5/ On my computer, I run 'pageant.exe'.
>> 6/ I click on 'Add key'. I load the file 'private.ppk'
>> 7/ I close 'pageant.exe' (still actif in the task bar).
>> 8/ I open explorer. I create a directory that is suppose to be the local
>> directoy for the projet.
>> 9/ I right-click on the directory. I open 'SVN checkout'
>> 10/ In 'URL of  repository:', I write :
>> 'svn+ssh://christophe@svn.r-forge.r-project.org/svnroot/kml3d'
>> (christophe is my accoung, kml3d is the project)
>> And...
>> ...nothing happen. No bug, not warning, nothing.
>> I try several things: if I do
>> 'svn://christophe@svn.r-forge.r-project.org/svnroot/kml3d', I do manage to
>> download the project. But then, I do not manage to upload some modification.
> All looks ok, but I think you are using the wrong protocol. It should be 'svn+ssh' for *commits*, i.e.
> svn+ssh://christophe@svn.r-forge.r-project.org/svnroot/kml3d
> which *is* shown at http://r-forge.r-project.org/scm/?group_id=727

Sorry, I missed that you've tried that (I scrolled past it on my small screen).

- When you generated a key in PUTTYgen, did you enter a passphrase?  I
think you have to leave that blank.

- Make sure not to have any newlines/spaces in the key, when you paste
it, that is, you should have:

Line 1: ssh-rsa
Line 2: <long key>

You can have multiple entries as the above.

- You need to checkout with the svn+ssh URL, because that it is what
TortoiseSVN will use for commits (unless you do "relocate").  If you
can checkout using this protocol, you should be able to commit.  Thus,
focus your troubleshooting on checking out.

- In the "Default Settings" PuTTY Configurations, make sure "Attempt
authentication using Pageant" is checked under the Connection -> SSH
-> Auth panel.

- Make sure Pageant lists the key in its dialog.

Does it work?


> /Henrik
> PS. Don't think you need plink, but I might be wrong.
>> I also see on some tutorial that we might need putty.exe or plink.exe. I
>> download them, but R-Forge user Manual do not mention them.
>> Any idea of what goes wrong ?
>> Thanks
>> Christophe
>> ______________________________________________
>> R-devel at r-project.org mailing list
>> https://stat.ethz.ch/mailman/listinfo/r-devel

More information about the R-devel mailing list